PHP linked against libpthread on XAMPP?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

PHP linked against libpthread on XAMPP?

Postby Joseba » 29. April 2006 14:11

Hi. I hope someone can help me please.

I need to use the PHP API of the Berkeley XML data-base system. The install script tells me as a warning this:

The db4 c++ library by default tries to link against libpthread on some
systems (notably Linux). If your PHP install is not linked against
libpthread, you will need to disable pthread support in db4. This can
be done by compiling db4 with the flag --with-mutex=x86/gcc-assembly.
PHP can itself be forced to link against libpthread either by manually editing its build files (which some distributions do), or by building it with
--with-experimental-zts.


It's XAMPP PHP linked against libpthread? if not, can I do it? how? Or can I use that with-experimental-zts option?

Thanks. Cya.
Joseba
 
Posts: 4
Joined: 29. April 2006 13:30

Postby Joseba » 25. May 2006 09:11

Well, maybe someone it's interested..

If you want to know which libraries are linked with php, simply run:
ldd `which php`

Cya
Joseba
 
Posts: 4
Joined: 29. April 2006 13:30


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests