No InnoDB For MySQL In XAMPP 1.5.1?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

No InnoDB For MySQL In XAMPP 1.5.1?

Postby thejoker101 » 04. April 2006 16:01

Any particular reason why?

Also, how can I enable it? I would like to use transactions and myisam doesn't support them.
thejoker101
 
Posts: 7
Joined: 24. March 2006 16:30

Postby Hayce » 06. July 2006 00:26

I found this from google, its old but maybe others get stuck with it...

Go to your "my.cnf" file (should be in: path/to/xampp/mysql/bin/ )

Open it up in a text editor (I use scintilla sc1) and find the lines:

Code: Select all
skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:/xampp/xampp/mysql/data/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:/xampp/xampp/mysql/data/
#innodb_log_arch_dir = C:/xampp/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50


Change (uncomment) them to the following:

Code: Select all
#skip-innodb
# Uncomment the following if you are using InnoDB tables
innodb_data_home_dir = C:/xampp/xampp/mysql/data/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = C:/xampp/xampp/mysql/data/
innodb_log_arch_dir = C:/xampp/xampp/mysql/data/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
set-variable = innodb_buffer_pool_size=16M
set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
set-variable = innodb_log_file_size=5M
set-variable = innodb_log_buffer_size=8M
innodb_flush_log_at_trx_commit=1
set-variable = innodb_lock_wait_timeout=50


restart.

That worked for me.
Hayce
 
Posts: 5
Joined: 22. June 2006 00:36


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests