Cannot upload files

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Cannot upload files

Postby perikitto » 31. March 2006 20:10

Hello everybody!!!!

I've decided to change my windows personal server for a linux one, much more stable but also much much more dificult :oops: expecially to someone like me.

So, i´m using XAMPP but i´m having a big problem all over the start.

CANNOT UPLOAD files. I´m trying a lot of php scripts but none works.

Yes, uploads are on , safe mode is off, i´m chmoding folders to 777 and ownership to nobody and nogroup.

I dont know if it is important, but, I´m trying this stuff on my lan from a win pc acessing the linux server with http://192.168.1.2/

HELP PLEASE
THANKS in advance
perikitto
 
Posts: 11
Joined: 31. March 2006 19:54

Postby thorsin » 01. April 2006 11:05

there is a folder for uploaded files, make sure this one is writeable for the apache-user...
Code: Select all
php.ini:
; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir
User avatar
thorsin
 
Posts: 136
Joined: 05. March 2006 20:39

Postby Baphomet » 03. April 2006 17:57

I have this problem too, I have a few questions.

Who is "the apache user"?

I set that to:
upload_tmp_dir = /opt/lampp/tmp/
(Copied and pasted from php.ini)

I've tried everything permission-wise with the directory tmp in /opt/lampp including setting ALL permissions, read, write execute for user, group and other. Uploads still fail.

Help is apreciated.
Baphomet
 
Posts: 1
Joined: 03. April 2006 17:51

Postby perikitto » 04. April 2006 01:38

Yes, uploads are on , safe mode is off, i´m chmoding folders to 777

I set that to:
upload_tmp_dir = /opt/lampp/tmp/
(Copied and pasted from php.ini)

That you have to do in php.ini , that and set the apropriate upload file size for you also in php.ini.

That was what I've done, and you know what?!!! IT DIDN'T WORK LOL
But then I've restarted the server and when I say server I mean server and not only xampp and things strated to work

VERY Wyard :?:
perikitto
 
Posts: 11
Joined: 31. March 2006 19:54

Postby thorsin » 04. April 2006 09:19

Baphomet wrote:Who is "the apache user"?


debian-linux: www-data
windows: system
gentoo-linux: www
....
User avatar
thorsin
 
Posts: 136
Joined: 05. March 2006 20:39

Postby Geek » 09. November 2008 05:53

I am having the same issue. I am a xampp noob. But I have set all file permissions etc. Have tried to upload even a simple image on several scripts as well as mods on others such as joomla. I dont know where to go from here. I am using Ubuntu.

Any help on where to go would be appreciated. Thanks
Geek
 
Posts: 2
Joined: 09. November 2008 05:51

Postby Geek » 09. November 2008 06:20

SOLVED THE PROBLEM in your php.ini file


Change
Code: Select all
max_execution_time = 30     ; Maximum execution time of each script, in seconds
memory_limit = 8M      ; Maximum amount of memory a script may consume (8MB)


to

Code: Select all
max_execution_time = 120     ; Maximum execution time of each script, in seconds
memory_limit = 64M      ; Maximum amount of memory a script may consume (64MB)


go to your terminal and restart xampp

/opt/lampp/lampp restart

no more problems YAY!!!! :lol:
Geek
 
Posts: 2
Joined: 09. November 2008 05:51


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests