Page 1 of 1

eaccelerator extension not working with PHP5

PostPosted: 25. January 2006 03:18
by emeyer
Get undefined symbol. error on launch. On research this appears to be a problem with eaccelerator not working on php5?

PostPosted: 25. January 2006 08:53
by LazyOne
try the 5.1 snapshot.. but it seems not to work right now with php 5.1

PostPosted: 25. January 2006 19:31
by emeyer
I tried with 1.5.1 distribution (from website) and first got the following message:

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/' - not found

So first I downloaded the sdk--same messsage.

So then I copied the file from ..extensions/2004xxxx folder to ..extnesions/2005xxxx folder and got the message:

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/ undefined symbol: OnUpdateInt in Unknown on line 0

I tried searching for OnUpdateInt at but it is not listed. On wide Internet search I found it mentioned somewhere (though not reliably) that it is a deprecated function. Maybe the 2004xxxx folder has the php4 in it and 2005xx has php5 in it but I cant tell.

I looked into recompiling php but I could not find the php makefile in the sdk, and with things moved around like they are I wasn't sure what I should do. If there are any step-by-step directions I'd be glad to follow them.

PostPosted: 27. January 2006 22:41
by christh21
I'm having the same problem. There is no compiled eAccelerator binary for the PHP 5.1.1 installation. Has anyone successfully compiled eAccelerator for PHP5.1.1 or do we have to use PHP4?

Same Problem!!!!

PostPosted: 09. February 2006 05:42
by ygor
Hi, i'm having the exact same problem....

i've even tryed to manually recompile the eaccelerator externally and put the binary int the php5 extensions folder but isn't work...

Anybody fixed this????

What u think about using Zend Optimizer instead of eAccelerator???

PostPosted: 09. February 2006 13:50
by LazyOne
zend optimizer is NO real php optimizer, then you need the zend suite.

PostPosted: 18. February 2006 21:04
by Alives
I'm having the same problem. Does it work if you use php4?

PostPosted: 18. February 2006 21:12
by LazyOne
snapshot (theres a new one from today..) or with rc2? rc2 should of course work without problem with php4, with php5 got still error (unkown in line 0 blabla) with the snapshot from today.

PostPosted: 19. February 2006 17:26
by LazyOne
now it works with php5.1.

dev package from xampp is required!

latest snapshot from eac.

and just source installation.

This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.1.0, Copyright (c) 1998-2005 Zend Technologies
with eAccelerator v0.9.5-cvs20060219, Copyright (c) 2004-2004 eAccelerator, by eAccelerator

PostPosted: 19. February 2006 21:55
by christh21
Does anyone know how eAccelerator performs in FastCGI mode?

PostPosted: 14. March 2006 11:45
by als_2014
is there a solution now ?