eaccelerator extension not working with PHP5

Problems with the Linux version of XAMPP, questions, comments, and anything related.

eaccelerator extension not working with PHP5

Postby emeyer » 25. January 2006 03:18

Get undefined symbol. error on launch. On research this appears to be a problem with eaccelerator not working on php5?
emeyer
 
Posts: 2
Joined: 25. January 2006 02:55

Postby LazyOne » 25. January 2006 08:53

try the 5.1 snapshot.. but it seems not to work right now with php 5.1

http://snapshots.eaccelerator.net/
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby emeyer » 25. January 2006 19:31

I tried with 1.5.1 distribution (from website) and first got the following message:


PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/eaccelerator.so' - not found

So first I downloaded the sdk--same messsage.

So then I copied the eaccelerator.so file from ..extensions/2004xxxx folder to ..extnesions/2005xxxx folder and got the message:

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/eaccelerator.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20050922/eaccelerator.so: undefined symbol: OnUpdateInt in Unknown on line 0

I tried searching for OnUpdateInt at php.net but it is not listed. On wide Internet search I found it mentioned somewhere (though not reliably) that it is a deprecated function. Maybe the 2004xxxx folder has the php4 in it and 2005xx has php5 in it but I cant tell.

I looked into recompiling php but I could not find the php makefile in the sdk, and with things moved around like they are I wasn't sure what I should do. If there are any step-by-step directions I'd be glad to follow them.
emeyer
 
Posts: 2
Joined: 25. January 2006 02:55

Postby christh21 » 27. January 2006 22:41

I'm having the same problem. There is no compiled eAccelerator binary for the PHP 5.1.1 installation. Has anyone successfully compiled eAccelerator for PHP5.1.1 or do we have to use PHP4?
christh21
 
Posts: 11
Joined: 13. September 2004 04:30

Same Problem!!!!

Postby ygor » 09. February 2006 05:42

Hi, i'm having the exact same problem....

i've even tryed to manually recompile the eaccelerator externally and put the binary int the php5 extensions folder but isn't work...

Anybody fixed this????

What u think about using Zend Optimizer instead of eAccelerator???
User avatar
ygor
 
Posts: 4
Joined: 09. February 2006 05:19
Location: Ribeirão Preto/SP - Brazil

Postby LazyOne » 09. February 2006 13:50

zend optimizer is NO real php optimizer, then you need the zend suite.
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby Alives » 18. February 2006 21:04

I'm having the same problem. Does it work if you use php4?
Alives
 
Posts: 1
Joined: 18. February 2006 21:03

Postby LazyOne » 18. February 2006 21:12

snapshot (theres a new one from today..) or with rc2? rc2 should of course work without problem with php4, with php5 got still error (unkown in line 0 blabla) with the snapshot from today.
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby LazyOne » 19. February 2006 17:26

now it works with php5.1.

dev package from xampp is required!

latest snapshot from eac.

and just source installation.


This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.1.0, Copyright (c) 1998-2005 Zend Technologies
with eAccelerator v0.9.5-cvs20060219, Copyright (c) 2004-2004 eAccelerator, by eAccelerator
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby christh21 » 19. February 2006 21:55

Does anyone know how eAccelerator performs in FastCGI mode?
christh21
 
Posts: 11
Joined: 13. September 2004 04:30

Postby als_2014 » 14. March 2006 11:45

is there a solution now ?
als_2014
 
Posts: 1
Joined: 14. March 2006 07:16


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests