New Install not displaying images or Backgrounds

Problems with the Linux version of XAMPP, questions, comments, and anything related.

New Install not displaying images or Backgrounds

Postby DSLuser » 14. January 2006 20:59

I have just installed Xampp on an OLD PC running DSL (Hard Drive Install).

It all seemed to have set up properly(amazingly simple actually) and I can view pages from a browser on localhost and across my network (Other machines run win XP).

The problem is that I do not see any pictures or background images. ie orange side bar and Logo/header at top of default page. The strange thing is that if I view using https:// instead of http:// they are all perfect.

I have uploaded "cubecart" which is the reason for me trying to create a test environment and again can not see it properly unless using https://

Any help gratefully recieved.
DSLuser
 
Posts: 1
Joined: 14. January 2006 20:46

Postby LazyOne » 15. January 2006 13:40

sendfile on/off in http.conf?
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

same problem!

Postby mman » 16. January 2006 23:27

I just had the same problem. I installed xampp 1.5.0 without any problem on a new small linux box (debian sarge on pentium 166 mhz 32 mb ram 4gb hd!).

As soon i downloaded 1.5.1, I removed old version (rm -rf /opt/lampp) and made a fresh install: images and background weren't there anymore!
Logs seem to show nothing strange, but no new htm page I put in /opt/lampp/htdocs is shown; I followed the advice to call by https:// instead of http:// and THAT works!

I tried also to chance sendfile (I enabled "EnableSendfile on" in /opt/lampp/etc/httpd.conf), but it didn't work.

Perhaps there's a problem with secure pages, but I haven't enough knowledege to solve it.

Here is a snap from my /opt/lampp/logs/error_log(I don't know, anyway, i f real problem is here):

[Mon Jan 16 12:06:05 2006] [notice] Graceful restart requested, doing restart
[Mon Jan 16 12:06:05 2006] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
[Mon Jan 16 12:06:55 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Jan 16 12:06:55 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jan 16 12:06:55 2006] [notice] Digest: generating secret for digest authentication ...
[Mon Jan 16 12:06:55 2006] [notice] Digest: done
[Mon Jan 16 12:06:59 2006] [notice] Apache/2.2.0 (Unix) mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/5.1.1 mod_apreq2-20050712/2.1.3
-dev mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations


Has anyone any suggestion, please? Thanks

Maurizio
mman
 
Posts: 3
Joined: 16. January 2006 12:17

Re: New Install not displaying images or Backgrounds

Postby hoganz » 17. January 2006 13:36

DSLuser wrote:The problem is that I do not see any pictures or background images. ie orange side bar and Logo/header at top of default page.
Any help gratefully recieved.


I've got the same prob :?
hoganz
 
Posts: 5
Joined: 07. January 2005 14:41

Postby LazyOne » 17. January 2006 13:41

set sendfile to OFF in httpd. conf ?
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby mman » 17. January 2006 15:55

LazyOne wrote:set sendfile to OFF in httpd. conf ?


Your suggestion did the job! Thank you
I misunderstood your advice and I enabled sendfile instead of disabling it.
Now everything works, but in error_log i got:

[Tue Jan 17 15:45:17 2006] [notice] Graceful restart requested, doing restart
[Tue Jan 17 15:45:17 2006] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)

Should I worry about it? (I apologize for my ingenuity, i'm newby to apache)

Maurizio
mman
 
Posts: 3
Joined: 16. January 2006 12:17

Postby LazyOne » 17. January 2006 16:13

i think you shouldn`t worry about it, thats because sendfile off i think (or?), maybe set errorlog to off if all runs fine like i do, speed matters..

but i`m no professional, i dont know if i`m right with that opinion.
LazyOne
 
Posts: 141
Joined: 12. May 2005 12:12
Location: München

Postby mman » 17. January 2006 16:41

LazyOne wrote: maybe set errorlog to off if all runs fine like i do, speed matters..


ok, you're right... on a slow box like the one I'm testing any time-saving trick is welcome

Thank you again
Maurizio
mman
 
Posts: 3
Joined: 16. January 2006 12:17


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 1 guest