postgresql addon startup problem..unable to open libpam.so.0

Problems with the Linux version of XAMPP, questions, comments, and anything related.

postgresql addon startup problem..unable to open libpam.so.0

Postby njiggs » 05. January 2006 12:04

I am using XAMPP 1.4.14 on ubuntu 5.04...just installed the postgresql addon ( postgresql-addon-0.6) as per instructions on http://addons.xampp.org/cgi-bin/search.pl?pid=21 ...now when i try to start postgresql, i get this error..

Code: Select all
root@***:/home/**/postgresql-addon # /opt/lampp/lampp startpostgresql
Starting PostgreSQL
/opt/lampp/bin/pg_ctl: error while loading shared libraries: libpam.so.0: cannot open shared object file: No such file or directory


i checked for permissions on the only libpam.so.0 file that i found on the entire / (that was there in /lib/libpam.so.0 and was a link to /lib/libpam.so.0.76)...

Code: Select all
lrwxrwxrwx  1 root root    14 2005-10-23 22:08 /lib/libpam.so.0 -> libpam.so.0.76
-rw-r--r--  1 root root 37288 2004-10-26 20:21 /lib/libpam.so.0.76


i even tried adding execute permission to libpam.so.0.76 file for owner but still i get the same problem...can someone tell me what the problem is? and how to solve it...

thanks!!
njiggs
 
Posts: 18
Joined: 20. July 2005 05:47

Postby njiggs » 18. January 2006 20:27

doesnt anyone have any idea as to why i am getting this error?!? i have been trying to find a solution but nothing has worked for me...Please help me out on this...
njiggs
 
Posts: 18
Joined: 20. July 2005 05:47


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests