MySQL unavailible

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySQL unavailible

Postby Erwan » 02. November 2005 00:38

Hi there!

Well all was working fine but now....

OK so I am running PHP-nuke on my sever using xampp. All was fine untill I ran the security script for xampp. What happens now when I try to access my website it comes up with

"There seems to be a problem with the MySQL server, sorry for the inconvenience.

We should be back shortly."

Yet mySQL start properly, and I can access phpmyadmin fine. I reloaded my databse from a backup and still the same thing. Is there anyway to "un"-secure it again temporarly to see if that was infact the problem?

THanks!

E
Erwan
 
Posts: 2
Joined: 02. November 2005 00:31

Postby deepsurfer » 02. November 2005 00:55

try to switch xampp to PHP4 , i know of phpNuke Versions that dont work with PHP5..
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Erwan » 02. November 2005 01:02

I tried that as well, same thing.

If I wanted to just re-install xampp so that is start as a fresh install, can I just del the

/opt/lammp

folder? and then reinstall it? or does it change other system settings that need to be removed?

E
Erwan
 
Posts: 2
Joined: 02. November 2005 00:31

Postby krelvinaz » 02. November 2005 05:21

Make sure you export your databases first.
Kevin
User avatar
krelvinaz
 
Posts: 79
Joined: 02. October 2005 05:46
Location: Mesa, AZ USA

Postby DerUnglaublicheFloonsh » 03. January 2006 14:42

hmm i got the same problem after changing the password of MySQL's root user, try setting it back to whatever worked before
DerUnglaublicheFloonsh
 
Posts: 1
Joined: 03. January 2006 14:37

Postby schonning » 05. January 2006 19:40

I had to add the root password in cds.php for it to work after running the security script.

Code: Select all
dsl@box:/opt/lampp/htdocs/xampp$ more cds.php
<?
        if($_REQUEST['action']=="getpdf")
        {
                mysql_connect("localhost","root","mynewpassword");
                mysql_select_db("cdcol");


Maybe you need to add your new password to the nuke script?
User avatar
schonning
 
Posts: 5
Joined: 31. December 2005 19:02


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests