file-get-contents fails and results in no homepage

Problems with the Linux version of XAMPP, questions, comments, and anything related.

file-get-contents fails and results in no homepage

Postby th1alb » 01. November 2005 02:59

So I got XAMPP installed just fine. However, when I go to http://localhost I get this:
[code]
Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4
[/code]
Ummm...any ideas? Are there file permissions that need to be set? I was under the impression that permissions didn't have to be explicitly set by the user. Thanks in advance!
th1alb
 
Posts: 98
Joined: 31. August 2005 21:14

Postby Wiedmann » 01. November 2005 03:26

You must follow the installation instructions exactly.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby schonning » 31. December 2005 19:06

I know this is an old post, but I just wanted to say that I needed to change write permission on lang.tmp to 666 in order to make it work.

Should I have done something else? I have read all FAQ and instructions that I know about...

I also recieve this error when I try to open phpMyAdmin:

Code: Select all
Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

Warning: Unknown: Failed opening '/ramdisk/opt/lampp/phpmyadmin/config.inc.php' for inclusion (include_path='.:/opt/lampp/lib/php') in Unknown on line 0


I can locate the directory php in the given path: /opt/lampp/lib/php, is this related to the lang.tmp problem above?
User avatar
schonning
 
Posts: 5
Joined: 31. December 2005 19:02

Postby Wiedmann » 31. December 2005 20:13

'/ramdisk/opt/lampp/phpmyadmin/config.inc.php'

What is this "/ramdisk"?

The path should only be "/opt/lampp".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby schonning » 31. December 2005 20:17

I found the problem.

I wasn't logged in as root when I did the un-tar on the xampp package.
User avatar
schonning
 
Posts: 5
Joined: 31. December 2005 19:02

Postby schonning » 31. December 2005 20:18

I think I get ramdisc because I use DSL (Damn Small Linux) and that OS is only 50MB and I have an boot option to load the OS into ram memory at boot up :P


Thank you for a kick-ass application/websever!! :twisted:
User avatar
schonning
 
Posts: 5
Joined: 31. December 2005 19:02


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests