apache config local IP net URL - shareware inconsistent

Problems with the Linux version of XAMPP, questions, comments, and anything related.

apache config local IP net URL - shareware inconsistent

Postby richfm » 26. October 2005 13:51

Here goes my explanation...

The webserver is inconsistent in resolving addresses when
using freeware, OK either LAN access or WAN accesses but not
both

I think this is because the URL I give the shareware during
loading. But this in turn is really to do with (I think) the
Apache server settings.

For example on the LAN if I type http://10.0.0.12
(the local address for the webserver) this works fine but not
http://www.mysite.com

In addition I use web forwarding for the URL mapping the
client to the IP address of my broadband connection which
goes through the router. The router has a virtual server
which maps from the public port 80 on the router to the
private port 80 port type TCP on the web server.

NB: I've also set up ports 443 and 25 (FTP and email)
neither of which work.

I'm a newbie as far as Apache and networks are concerned but
I think this issue is to do with the fact I do not have the
settings right.

I think I missed the lesson on Vritual Hosts,DNSs and Sever
names. I've dabbled but my IQ level appears to have taken a
nose dive.

Please help
richfm
 
Posts: 1
Joined: 04. September 2005 09:03
Location: UK

Postby Wiedmann » 26. October 2005 14:02

For example on the LAN if I type http://10.0.0.12
(the local address for the webserver) this works fine but not
http://www.mysite.com

Taht's normal. In you local net you can not use the dns name, or better the public ip from your router, to access you local webserver.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests