VirtualHosts ?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

VirtualHosts ?

Postby tamamanquitaime » 21. October 2005 13:13

Hello everybody,

First please excuse my english,

I'm trying to be the webmaster of the website of my institute, as noone was able to do that. Of course I'm rather ignorant in configuring Apache.

Actually, I run Apache by Xammp on an Ubuntu Hoary. I have an IP adress, and two aliases for this IP.


I thought I had found what was to be done : use the directive "VirtualHost". I found a few explanations telling me how to edit the Apache files. The problem is that those files do not exist on my system, since I have used Xammp.

Could anyone tell me how to do this ? Thanks a lot
Last edited by tamamanquitaime on 05. March 2006 09:10, edited 1 time in total.
tamamanquitaime
 
Posts: 6
Joined: 21. October 2005 13:05

Postby Wiedmann » 21. October 2005 13:40

I found a few explanations telling me how to edit the Apache files. The problem is that those files do not exist on my system, since I have used Xammp.

Which files don't exists?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tamamanquitaime » 21. October 2005 13:56

For example :

/etc/httpd/conf/vhosts/Vhosts.conf

I tried to find it in /opt/lampp/etc/, but that ain't there. The problem is that this file does not exist even on my personal computer, on which Apache was installed the classical way (apt-get install apache-common). I just don't know Apache well enough to guess if the configuration I read about was typical or not, if my installation is not standard or whatever.

I tried to modify /opt/lampp/etc/httpd.conf uncommenting the lines in <VirtualHosts> and modifying them, but that just doesn't work : after doing this, any access would lead me to the geom/ dir...

Mybe should I try to add two virtualhosts, one for igat and the other one for geom ?

Thanks again
tamamanquitaime
 
Posts: 6
Joined: 21. October 2005 13:05

Postby Wiedmann » 21. October 2005 14:02

I tried to modify /opt/lampp/etc/httpd.conf

This is the correct configuration file.

Here you can find an example how to configure a vhost:
http://community.apachefriends.org/f/viewtopi ... host#34538

And don't forgett the official Apache manual...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tamamanquitaime » 21. October 2005 15:08

Thanks ! It works very fine :)
tamamanquitaime
 
Posts: 6
Joined: 21. October 2005 13:05


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests