Problem with FTP, need assistance

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem with FTP, need assistance

Postby eliter4v3n » 18. October 2005 15:42

Hello, and thanks before hand if anyone can assist me in my problem.

I am running, fedora core 4 with the current version of Xampp [lampp]. Everything runs great, and better than other services i have installed and tried using on this fedora. But the only thing i can not get to work is the ProFTPD. It runs, but i get this when i try loggin in.
SmartFTP v1.5.990.2
Resolving host name "10.1.4.102"
Connecting to 10.1.4.102 Port: 21
Connected to 10.1.4.102.
220 ProFTPD 1.2.10 Server (Computer Technology FTP) [192.168.1.100]
USER cis
331 Password required for cis.
PASS (hidden)
230 User cis logged in.
SYST
215 UNIX Type: L8
FEAT
211-Features:
MDTM
REST STREAM
SIZE
211 End
PWD
257 "/" is current directory.
CWD /
250 CWD command successful
PWD
257 "/" is current directory.
TYPE I
200 Type set to I
PASV
227 Entering Passive Mode (192,168,1,100,128,34).
Opening data connection to 192.168.1.100 Port: 32802
LIST -aL
Timeout (20s).


I do not understand why it hangs in the first place. From looking through the forums, i thought i might have set the proftpd.conf right, but unfortunatly i must have not.

If anyone else has had this error, please let me know, or send me a pre-configured proftpd.conf that is known to work. I please hope i can get this issue solved soon, because this is kind of a project.

Thanks again, and if any more information is needed, please let me know and ill get you whatever you need to help me.

[Jon]
eliter4v3n
 
Posts: 4
Joined: 18. October 2005 15:28

Postby Wiedmann » 18. October 2005 17:17

There is something mysterious...

Connected to 10.1.4.102.
220 ProFTPD 1.2.10 Server (Computer Technology FTP) [192.168.1.100]

You connect to "10.1.4.102" and the server told you he is on "192.168.1.100".

That's a problem if you are ussing passive ftp:
227 Entering Passive Mode (192,168,1,100,128,34).
Opening data connection to 192.168.1.100 Port: 32802

After that, your client want/must connect to "192.168.1.100"...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby eliter4v3n » 19. October 2005 03:19

Ah, ok.

Yes in order for Fedora to be seen on my windows network i had to run the fedora boxes through a router. So the Computer connecting to the Fedora with ProFTPD installed is outside of the router. And it is windows.

But, i set port forwarding for my router, and forwarded port 21 twards the "192.168.1.100" Fedora Core with Xampp installed. I know about routing protocols and such, but im pretty sure that is correctly setup.

How might i make sure it does not enter passive ftp? and why might that be a problem?

Should i show my Proftpd.conf file so you can see what its trying to execute?

thanks again
[Jon]
eliter4v3n
 
Posts: 4
Joined: 18. October 2005 15:28

Postby Wiedmann » 19. October 2005 05:01

and why might that be a problem?

Let me try to explain:

1) Connecting to 10.1.4.102 Port: 21
your client connect to the server

2) USER / PASS
your client told the server who you are

3) PASV
your client told the server he want to use passive ftp

4) 227 Entering Passive Mode (192,168,1,100,128,34).
your server answer the client:
please contact me at ip 192.168.1.100 / port 32802

--> That's the way passive ftp works

How might i make sure it does not enter passive ftp?

That's difficult. As you read, this is a setting of your client. And your client is configured to use passive as standard ftp mode.
a) configure your clients to use active ftp as standard mode ...
b) ... or disable passive ftp in the server. But only a few clients makes an automatic fallback to active ftp in this situation (SmartFTP is one of them).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby eliter4v3n » 19. October 2005 13:13

ah! Thank you.

In smartftp [client i use also] i just made sure that it connected through active not passive.

Thanks again, this is a life saver.
eliter4v3n
 
Posts: 4
Joined: 18. October 2005 15:28


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests