virtualhost doesn't work on xampp 1.4.16

Problems with the Linux version of XAMPP, questions, comments, and anything related.

virtualhost doesn't work on xampp 1.4.16

Postby stezzz » 07. October 2005 19:19

i'm new 2 this xampp, but in my first try with xampp it's just what i was looking for. always doing the lamp config over and over again, and already tried 2 make an shell script so the installation would be alot easier.
well nevermind about this.

I installed the stuff and made everything secure.
i copyed my backup webfiles and the vhost.conf (where i have my virtualhost settings in)
i just made a rule in my httpd.conf : Include vhost.conf
well when i try the dns names for my vhosts it just keep putting me 2 the xampp homepage, and i don't seem 2 get the vhost right.
But the vhosts worked perfectly on my older lamp configuration.

example of my vhost.conf:
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
DocumentRoot /home/www/vhosts/stezzz.cjb.net/httpdocs
ServerName www.stezzz.cjb.net
ServerAlias stezzz.cjb.net *.stezzz.cjb.net
TransferLog /home/www/vhosts/stezzz.cjb.net/logs/stezzz_cjb_net_access_log
ErrorLog /home/www/vhosts/stezzz.cjb.net/logs/stezzz_cjb_net_error_log
DirectoryIndex index.php shoutboxhelp.php
Alias /errordocs/ /home/www/vhosts/stezzz.cjb.net/errordocs/
ErrorDocument 400 /errordocs/400.html
ErrorDocument 401 /errordocs/401.html
ErrorDocument 402 /errordocs/402.html
ErrorDocument 403 /errordocs/403.html
ErrorDocument 404 /errordocs/404.html
</VirtualHost>

etc.


can somebody help me get this stuff working?
my webserver is now down for a week and i can't get this fixxed xD
stezzz
 
Posts: 6
Joined: 06. October 2005 03:19

Postby stezzz » 07. October 2005 23:19

hmmz stil no reply :S well i heard about xampp having virtual host problems, but well plz help me fix this.

i didn't change anything in the httpc.conf accept adding 1 line :
Include vhost.conf
and in the vhost.conf i already posted that.
so what is wrong in the virtual host that it doesn't work prob.?
stezzz
 
Posts: 6
Joined: 06. October 2005 03:19

Postby Wiedmann » 07. October 2005 23:38

i didn't change anything in the httpc.conf accept adding 1 line :
Code: Select all
Include vhost.conf

You mean:
Code: Select all
Include conf/vhost.conf

:?:

Code: Select all
DocumentRoot /home/www/vhosts/stezzz.cjb.net/httpdocs

This is a path on your Windows system?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby stezzz » 08. October 2005 00:31

no no, i installed a clean linuc debian 3.1 os.
and i put the vhost.conf in /opt/lampp/etc where httpd.conf also is located.
stezzz
 
Posts: 6
Joined: 06. October 2005 03:19

Postby stezzz » 08. October 2005 00:33

i see i have 2 use etc/vhost.conf
let me try if that works xD
stezzz
 
Posts: 6
Joined: 06. October 2005 03:19

Postby stezzz » 08. October 2005 00:36

sweet i have it fixxed xD
stezzz
 
Posts: 6
Joined: 06. October 2005 03:19

Postby Wiedmann » 08. October 2005 00:51

sweet i have it fixxed

Fine :-) How?

no no, i installed a clean linuc debian 3.1 os.

Next time you should use the Linux forum and not that one for Windows ;-)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests