XSLT support on XAMPP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XSLT support on XAMPP

Postby prasad » 03. October 2005 13:23

hi everybody,
I have installed XAMPP just now, but I am not able 2 find XSLT support for SABLATRON in XAMPP.
the library seems 2 b installed..but the PHP does not seem to be configured with option --enable-xslt --with-xslt-sablot kind of things.

Can somebody plz help...i am sure there must be someway to get sablatron working in XAMPP.

(and also..do we need 2 take some extra efforts to start using MYSQL in XAMPP)

Regards,
Prasad.
prasad
 
Posts: 3
Joined: 03. October 2005 13:15

Postby Wiedmann » 03. October 2005 13:29

Which XAMPP/PHP?

XAMPP for Linux 1.4.16 / PHP5.05 have:
Code: Select all
'--enable-xslt' '--with-xslt-sablot=/opt/lampp'


(and also..do we need 2 take some extra efforts to start using MYSQL in XAMPP)

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby prasad » 03. October 2005 13:33

thanks wierdman for the fast reply..

can u please also tell me...where to write this
'--enable-xslt' '--with-xslt-sablot=/opt/lampp'

what I know is we use it at the time of configuration ..i mean while ./configure of php

but in this case I am confused as to where to perform the configuration

a quick reply will b appreciated..

Thanks

Prasad.
prasad
 
Posts: 3
Joined: 03. October 2005 13:15

Postby Wiedmann » 03. October 2005 13:53

can u please also tell me...where to write this

No. This is allready done for XAMPP PHP. You can see this in phpinfo().

Or you must compile PHP at yourself:
download the source, extract it and use configure with these switches.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby prasad » 03. October 2005 14:10

ok thanks..
i just found that
sablot is enabled but it is in php-4.4 of the LAMPP

but the current version running is php-5.0 which does not support sablot..

so can you please help with how to start PHP4 version instead of PHP5

Prasad
prasad
 
Posts: 3
Joined: 03. October 2005 13:15

Postby Spechal » 07. October 2005 07:27

Note to XAMPP since version 1.4.7
Because such very new versions like PHP 5 always should be handled with care we decided to include both current versions of PHP into XAMPP: PHP 5.0.x and PHP 4.3.x. If you find out your PHP application doesn't work with PHP 5 you will be able to switch back easily to PHP 4.

By the following command you can switch "back" to PHP 4.3.x:

/opt/lampp/lampp php4

And with the following command you can switch back to PHP 5.0.x:

/opt/lampp/lampp php5

If you forgot which version of PHP is in use simply use phpinfo() or call this command:

/opt/lampp/lampp phpstatus


http://www.apachefriends.org/en/xampp-linux.html
Spechal
 
Posts: 2
Joined: 07. October 2005 06:49


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests