Apache cannot use PHP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache cannot use PHP

Postby knurft » 28. September 2005 22:32

Want to use php in apache 2.0.54. All it does (tried a lot) is downloading the .php-file instead of running this file

I am running manrake 10.0

I noticed that the PATH does not include /opt/lampp to find php

Using xampp 1.4.16

Thanks
knurft
 
Posts: 5
Joined: 25. September 2005 12:39

Postby Wiedmann » 28. September 2005 22:49

All it does (tried a lot) is downloading the .php-file instead of running this file
...
Using xampp 1.4.16

You are using a URI like http://localhost/foo.php in a webbrowser?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Apache and PHP

Postby knurft » 29. September 2005 21:48

You are using a URI like http://localhost/foo.php in a webbrowser?


No I use it remote like http://www.hostname.tld
knurft
 
Posts: 5
Joined: 25. September 2005 12:39

Postby deepsurfer » 29. September 2005 22:05

do you see the xampp-welcomescreen with all functions ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Found solution!

Postby knurft » 30. September 2005 09:34

deepsurfer wrote:do you see the xampp-welcomescreen with all functions ?


Found solution.

I copied /opt/xampp/bin/php to /usr/bin and than I got the welcomescreen.
Must havebeen something with an old (default) installation.

The copy is not the best solution I like to make in these situations, any better solutions will be welcome.
knurft
 
Posts: 5
Joined: 25. September 2005 12:39

Postby Wiedmann » 30. September 2005 09:50

Found solution.
I copied /opt/xampp/bin/php to /usr/bin and than I got the welcomescreen.

You are really using a XAMPP (Apache from XAMPP)?

Because Apache from XAMPP use the PHP module and not the cgi.
--> you can delete this file and PHP must work in Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests