Autostart Lampp (Power Failures)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Autostart Lampp (Power Failures)

Postby johngoodman » 12. August 2005 08:29

I am running suse linux and would like to embed the startup command of "/opt/lampp/lampp start" so if there is a power failure I don't have to be present to start the server up again. :?
johngoodman
 
Posts: 6
Joined: 12. August 2005 08:25

Postby rickh57 » 12. August 2005 17:02

There are already quite a few threads for solving this issue. Try search! Here's one that I used: http://community.apachefriends.org/f/viewtopic.php?t=4606&highlight=boot.
rickh57
 
Posts: 25
Joined: 28. April 2005 17:12

In: command not found

Postby johngoodman » 12. August 2005 19:47

I tried the link provided and created both the lampp_start and lampp_stop files and placed them in /opt/lampp and set chmod to 755 and then went to /etc/rc.d/rc5.d since I am runlevel 5 and executed the following command:

In -s /opt/lampp/lampp_start S99lampp

I get error:

In: command not found

I am running SUSE linux. Any ideas or alternate methods of making lampp autorun at startup?

Thanks
johngoodman
 
Posts: 6
Joined: 12. August 2005 08:25

Update

Postby johngoodman » 12. August 2005 20:07

I realized I made a typing error ... "In" (IN) should have been "ln" (LN), but it still doesn't start the web server when I restart the computer.

Thanks!
johngoodman
 
Posts: 6
Joined: 12. August 2005 08:25

BINGO!

Postby johngoodman » 12. August 2005 20:23

I tried the above steps one more time. I shut down the server. I turned on the server and didn't log in. I went to another computer and entered the web URL and Walla!

Thanks for your help sir! Hope this thread helps others as well.

John :D
johngoodman
 
Posts: 6
Joined: 12. August 2005 08:25


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests