how to recompile php to work with Zend Studio

Problems with the Linux version of XAMPP, questions, comments, and anything related.

how to recompile php to work with Zend Studio

Postby pixelhed » 10. August 2005 10:46

Hi

I have tried to install Zend Studio server with lampp 1.4.14 but i get an error.
I have asked Zend support what to do, and they say i should recompile php without the option --enable-versioning.

I have downloaded the Development package and copied it to the correct location.

I realise now that i am not sure of the steps to recompile php, can someone please tell me the commands, as i have not done this before.

Thanks in advance

What i really need to know is in which directory do i issue ./configure [opts] ?
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34

Postby Wiedmann » 10. August 2005 13:29

What i really need to know is in which directory do i issue ./configure [opts] ?

You need the PHP source code, too.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby pixelhed » 10. August 2005 17:14

Wiedmann wrote:You need the PHP source code, too.


Hi, thanks for your answer

So i have to download the php source code from php.net. Where do i put it in the lampp directory tree, or is that not important?
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34

Postby pixelhed » 12. August 2005 13:52

i have downloaded the php source, and tried to compile it using the opts (excluding --enable-versioning) configure keeps failing.

I am compiling on Fedora core 3 AMD 64. Is this a problem?

the error messages i get are like this:
Code: Select all
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libgdbm.so when searching for -lgdbm
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libcurl.so when searching for -lcurl
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libssl.so when searching for -lssl
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libcrypto.so when searching for -lcrypto
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libxml2.so when searching for -lxml2
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libcurl.so when searching for -lcurl
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libssl.so when searching for -lssl
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libcrypto.so when searching for -lcrypto
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libssl.so when searching for -lssl
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libcrypto.so when searching for -lcrypto
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libz.so when searching for -lz
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libxml2.so when searching for -lxml2
/usr/bin/ld: skipping incompatible /opt/lampp/lib/libz.so when searching for -lz


Can anyone suggest how i can recompile php on my platform?
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34

Postby pixelhed » 29. August 2005 17:51

ok, i can see that the problem was trying to compile php on the 86_64 platform, as configure was looking in /lib for libraries. These were not compatible.

So i have installed xampp on a 32 bit system, and tried to recompile without the --enable-versioning option, but i keep getting errors.

I hope someone can help me understand the output of the config.log file, as i do not know what the error is:

http://www.pixel-works.co.uk/config.log

Or maybe someone would be kind enough to recompile php-5.0.4 without the --enable-versioning option so that i can see if this allows me to enable the zend debugger, on my xampp installation.

best regards
Andre
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34

Willing to pay for help setting up zend studio server

Postby pixelhed » 18. October 2005 11:14

Hi

Well i have tried everything i can think of and i cannot get zend studio server to work with lampp. If someone would like to earn some money showing me what to do, please contact me.

I need this module, so please help

Thanks
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34

have zend studio debugger working now

Postby pixelhed » 17. April 2006 10:19

Hi All

After a few months of ignoring this issue, then more time trying things that didn't work. I have figured out how to get Zend studio server working on my fedora x86_64 installation of XAMPP.

First i downloaded & installed the 32 bit version of Zend Studio Server - i did this as i thought that the original LAMPP was compiled on a 32 bit system.

Then i tried some diff options in php.ini, with the following i got the system running. Now i have debugging on the server - 8)

I did not want the Zend optimizer, as i use e-accelerator

Code: Select all
[Zend]
studio.install_dir=/usr/local/Zend
zend_debugger.expose_remotely=always
zend_debugger.httpd_uid=99
zend_gui_password={YOUR_MD5_PASS_HERE}
zend_gui.ini_modifier=/usr/local/Zend/sbin/ini_modifier
zend_debugger.allow_hosts=127.0.0.1/32,192.168.0.0/24
zend_debugger.allow_tunnel=127.0.0.1/32
zend_debugger.deny_hosts=
zend_root_dir=/usr/local/Zend
zend_server.apache_error_log=/opt/lampp/logs/error_log

zend_extension_manager.debug_server=/usr/local/Zend/lib/Debugger-5.1.0
zend_extension_manager.debug_server_ts=/usr/local/Zend/lib/Debugger-5.1.0

;commented out for compatability
;zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-2.6.1
;zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-2.6.1
;zend_extension=ZendExtensionManager.so

zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so
zend_extension_ts=ZendExtensionManager_TS.so


i hope someone finds this useful.

A
pixelhed
 
Posts: 7
Joined: 10. August 2005 10:34


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests