Access to my server from outside network ?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Access to my server from outside network ?

Postby boyce » 23. July 2005 10:43

Obviously a linux n00b ;)

I've had xampp setup on windows for ages with no problems, but thought i'd swith to linux [fedora core 3]

i've 4 or 5 virtual host's

i've edited httpd.conf to point to these
e.g

Code: Select all
<VirtualHost *:80>
ServerName www.ap0calypse.info
DocumentRoot opt/lampp/htdocs/domains/apocalypse
</VirtualHost>


When i access www.ap0calypse.info from a windows machine on my lan
it works fine (having edited my hosts file in windows)
it goes to the domain i type in

But

when i've asked others not on my lan to try it for me they get asked for a user name and password, as if it's ignoring the httpd.conf and just going to the lampp startpage.

anyhow i hope someone can point me in a useful direction :(

Thanks
boyce
 
Posts: 3
Joined: 19. May 2005 13:03

Postby Wiedmann » 23. July 2005 10:54

when i've asked others not on my lan to try it for me they get asked for a user name and password, as if it's ignoring the httpd.conf and just going to the lampp startpage.

Have you ever test "http://www.ap0calypse.info/" in your browser (without an entry in HOSTS)? What happens...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

..

Postby boyce » 23. July 2005 10:59

i get the request for the xampp user/pass etc :/

but i figured previously (probably wrongly) that was because of my router.
which has the ports forwarded etc

?

hmm appologies its not a lampp problem

it was my router config that peoiple were getting to

still no clue but ty anyhow

(edit agn) or is it i cannot tell as i cant access my web pages from the web because my router wont let me(/edit)
boyce
 
Posts: 3
Joined: 19. May 2005 13:03

well

Postby boyce » 24. July 2005 15:13

here's a bit from my error log

[Sun Jul 24 13:29:48 2005] [notice] Apache/2.0.54 (Unix) mod_ssl/2.0.54 OpenSSL/0.9.7g PHP/5.0.4 DAV/2 mod_perl/1.999.21 Perl/v5.8.6 configured -- resuming normal operations
[Sun Jul 24 13:29:58 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html
[Sun Jul 24 13:29:59 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html
[Sun Jul 24 13:29:59 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html
[Sun Jul 24 13:29:59 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html
[Sun Jul 24 13:31:32 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html
[Sun Jul 24 13:31:33 2005] [error] [client 10.0.0.7] (13)Permission denied: file permissions deny server access: /opt/lampp/htdocs/domains/botwars/index.html

^^ permissions denied appears alot :/ but i've tried setting them to 777 and still the same

http://www.botwars.co.uk

The above is the domain i'm now trying,

could someone take a look, i may even have it working, unlikely but you never know :)

Thanks
boyce
 
Posts: 3
Joined: 19. May 2005 13:03


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests