Erreur XAMPP et fedora core 4

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Erreur XAMPP et fedora core 4

Postby samiwt » 17. June 2005 12:20

quelqu'un pourrait m'aider s'il vous plait j'ai une erreur de demarrage avec fedora core4:
c'est comme http://community.apachefriends.org/f/viewtopic.php?t=12218
ce pendant j'ai pas trouvé de solution. Merci

[root@localhost ~]# /opt/lampp/lampp start
Starting XAMPP for Linux 1.4.13...
/opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/libcurl.so.3: cannot restore segment prot after reloc: Permission denied
XAMPP: Starting Apache with SSL ...
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
XAMPP: Error 127! Couln't start ProFTPD!
XAMPP for Linux started
samiwt
 
Posts: 9
Joined: 17. June 2005 12:13

Postby Ceelight » 17. June 2005 12:45

I have to answer in English, I hope you will understand this ;)

It seems, after reading the mentioned thread, that this setforce command should help you.

So after restarting your system type
Code: Select all
setforce 0


Hopefully one of the others can confirm this (or anwser in French ;) )??
There's no place like 127.0.0.1
User avatar
Ceelight
 
Posts: 295
Joined: 31. January 2004 19:57
Location: Pfälzer im niedersächsischen Exil ;-)

Postby Slasher » 29. June 2005 16:12

I had the same problem, that code works except that it has to be:

Code: Select all
setenforce 0


Thnx for ur help!

Greezz,

PS. I don't know any french either :P
Image
User avatar
Slasher
 
Posts: 1
Joined: 29. June 2005 16:06
Location: NL

Postby KarlaL » 11. July 2005 13:00

same problem here under fed 4. streange.
the workaround with setenforce 0 works for me, too. thanks.

can some1 explain, what this command does? -ty

(btw: english or german welcome ;) )
KarlaL
 
Posts: 11
Joined: 06. December 2004 15:05

FC4 Problem

Postby xtapa999 » 12. July 2005 04:21

"setenforce 0" disables SELINUX (the security "addins" that were added in FC3 and included in FC4). If you want to run in a secure environment you need SELINUX enabled.

What has worked for me is - - -
setenforce 0
/opt/lampp/lampp start
setenforce 1

Don't know all the "workings" og SELINUX but if I discover more I'll post it here.
xtapa999
 
Posts: 2
Joined: 12. July 2005 04:11
Location: Minnesota, United States

Postby xtapa999 » 12. July 2005 04:46

Further information on SELinux can be found at

http://www.nsa.gov/selinux/info/faq.cfm
xtapa999
 
Posts: 2
Joined: 12. July 2005 04:11
Location: Minnesota, United States


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests