Error 1! Couln'd start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Postby Oswald » 14. June 2005 20:16

Dear Rob! Dear Eric!

That's the first time I ever heard about this error. Very strange.

Rob: The first time (your posting from 14:57) you looked into the wrong error_log. You looked into the error_log from a Apache shipped with RedHat. The error_log from XAMPP's Apache is located under /opt/lampp/logs/. Just to explain this little matter. ;)

Could you both please simply call this both commands (one after the other):
/opt/lampp/bin/php-4.3.11 -v
/opt/lampp/bin/php-5.0.4 -v

What output do you get?

As far I can see from here PHP is no longer running on your systems. And because PHP is included into Apache the Apache also didn't start. But first I want to find out if PHP5 or PHP4 or both are affected.

Best regards
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Wiedmann » 14. June 2005 22:30

Jun 13 07:42:36 valence LAMPP: /opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied

You are using SELinux on your box?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kestrel_rob » 15. June 2005 09:27

Hi Oswald,

The output I get from /opt/lampp/bin/php-4.3.11 -v

PHP 4.3.11 (cli) (built: Apr 9 2005 19:28:12)
Copyright <c> 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


The output I get from /opt/lampp/bin/php-5.0.4 -v

PHP 4.0.4 (cli) (built: Apr 9 2005 19:34:32)
Copyright <c> 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby kestrel_rob » 15. June 2005 09:38

Eric,

My update agent log is worryingly empty, is this anything to worry about?
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby Oswald » 15. June 2005 09:50

Thank you, Rob!

That looks good. But what's about the question Wiedmann asks. Did you use SELinux? If yes please deactivate it by calling setenforce 0 and try to start XAMPP again.

Good luck
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby kestrel_rob » 15. June 2005 10:11

As far as I'm aware I'm not using SELinux (I am using Redhat Fedora) I tried setenforce 0 anyway.

I have just tried XAMPP again and get the error...

XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose ...
XAMPP: Make the httpd.conf fit your system.
XAMPP: Next try ...
XAMPP: Starting Apache with SSL (and PHP 5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

I have ckecked the httpd.conf file and it looks like it was overwritten by the default one, I put back my server details into it and tried it again.

It started up fine woithout any errors!!

The only thing I did was the setenforce 0!!!

Does that mean I am running a SELinux version?

Many thanks for your help guys!!!
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby Oswald » 15. June 2005 10:21

Dear Rob!

Yes, RedHat uses SELinux. (The name is mistakable: It's not a Linux, it's a security enhancement: Security-Enhanced Linux.)

setenforce 0 only disable it for the running system. After reboot it's active again. You can disable it permanently (via /etc/sysconfig/selinux). You should also be able to use SELinux, but configure it to allow XAMPP to run. But I never used it before and have no idea how to.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby kestrel_rob » 15. June 2005 10:26

Okay, many thanks for your help. The last update must have tweaked the security and made apache stop working as it was running fine before.

Cheers,

Rob
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

SElinux

Postby crazyman » 15. June 2005 14:32

http://www.nsa.gov/selinux/papers/policy2/x750.html
this might help us I think the policy in SElinux needs to be set I will look at my denied logs to see if I can figure it out and I will let you know if what I did worked or not ...as I fear a restart of my server will just enable SElinux with enforce mode again ...and I like SElinux.

Thanks this has really helped us. :)
~eric
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby scmeis1 » 15. June 2005 15:06

On the same note, with Fedora core 3, i did the same thing updated monday or tues. and now i get these errors.

Starting XAMPP for Linux 1.4.13...
/opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/mysql/l ibmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
XAMPP: Starting Apache with SSL ...
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: error while loading shared libraries: /opt/lampp /lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permis sion denied
XAMPP: Error 127! Couln't start ProFTPD!
XAMPP for Linux started.

I wiill dig deaper with my RHCE friend and see what the real issue is.


Scott
Last edited by scmeis1 on 16. June 2005 01:02, edited 1 time in total.
scmeis1
 
Posts: 2
Joined: 01. February 2005 13:00

port 22

Postby crazyman » 15. June 2005 15:59

does XAMPP utilize port 22?
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby Wiedmann » 15. June 2005 16:45

No. Port 22 is for SSH and have nothing to do with XAMPP.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Joining the bandwagon ...

Postby Roxie » 16. June 2005 17:02

Sorry to say, but you can include me in this topic. I'm having the same problems, or nearly so, it seems.

Starting XAMPP for Linux 1.4.13...
/opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
XAMPP: Starting Apache with SSL ...
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.

[root@dbs sources]# /opt/lampp/bin/php-4.3.11 -v
/opt/lampp/bin/php-4.3.11: error while loading shared libraries: /opt/lampp/lib/libcurl.so.3: cannot restore segment prot after reloc: Permission denied

[root@dbs sources]# /opt/lampp/bin/php-5.0.4 -v
/opt/lampp/bin/php-5.0.4: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
Roxie
 
Posts: 7
Joined: 16. June 2005 16:25

setenforce 0 after every restart

Postby crazyman » 16. June 2005 19:52

so far the fix is setenforce 0 after every restart of your system ...it is an SElinux denial after we updated FC3. I have been busy with other stuff, but there is a link further up that tells you how to let SElinux allow stuff ...it is a gov site ....if you figure out the prob first let us know ;)
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby jchord » 26. June 2005 00:24

two days ago i was using fedora core 3 with selinux and everthing worked fine...
today i installed fedora core 4 w/ selinux & nothing works any more

b.t.w. i get the exact same error that scott gets
jchord
 
Posts: 5
Joined: 13. May 2005 04:06

PreviousNext

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests