Error 1! Couln'd start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 1! Couln'd start Apache!

Postby kestrel_rob » 14. June 2005 13:35

Hi all,

I had installed XAMPP on my Linux Red Hat box and everything was running fine, however, this morning the desktop alert was flashing to show me that there were upgrades to install, and as I started to go through them I got distracted and installed everything, and now when I run "llamp start" I get the error...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/

MySql and ProFTPD start up ok.

I have tried running "tail -2 /opt/lampp/logs/error_log" but that just returns to the commands prompt seeminly without doing anything.

Now I don't know what was in the upgrade to make it stop working, any one got any thoughts on getting it up and running again?

Any help greatly appreciated!!

Rob
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby kestrel_rob » 14. June 2005 13:57

Ok, I have found an error log it states:

[notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[notice] LDAP: Built with OpenLDAP LDAP SDK
[notice] LDAP: SSL support unavailable
[notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[notice] Apache/2.0.52 (Fedora) configured -- resuming normal operations
[error] [client 127.0.0.1] File does not exist: /var/www/html/webalizer
[error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico

and the error repeats about 10 times down the page.

My initial thoughts are these:-
1. There are 0 max threads! - Is this okay?
2. I have installed XAMPP into /opt/lampp/ NOT /var/www/html - do i need to amend a configuration file somewhere, if so where is it?
3. The servers IP address is NOT 127.0.0.1 is this a standard setting or does this need to change to my correct IP (and should this be the internet IP or the external IP)?

Many thanks.

Rob
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby kestrel_rob » 14. June 2005 15:12

I have found more information on this, and in the "apachestart.log" is the following:

Syntax error on line 234 of /opt/lampp/etc/httpd.conf:
Cannot load /opt/lampp/modules/libphp5.so into server: /opt/lampp/modules/libphp5.so: cannot restore segment prot after reloc: Permission denied

Any help on this one?

Cheers,

Rob
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby kestrel_rob » 14. June 2005 17:14

I beleive the above error is the key, as the other log file hasn't changed all day, and I have been trying to start it up all day so I would have thought it would generate errors each time I try. However the log file for the error "Syntax error on line 234...." is updated each time I try to start apache.

More information:-
I'm using...
XAMPP 1.4.13
Apache 2.0.53
PHP 5.0.4 (I also have PHP 4.3.11)

Cheers,

Rob
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Same problem here

Postby crazyman » 14. June 2005 17:24

I am having the exact same problem as you are you using ssl? I am going to try (sigh!) and reconfigure it without ssl, I was just thinking maybe there is a bug running it with php and the certificates ...I'm guessing big time.
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby kestrel_rob » 14. June 2005 17:30

I didn't put SSL on, unless it was installed along with the rest of the stuff that came with XAMPP. Anyway I don't think I'm using it :?

Was yours working before you updated something, if so, do you know what you updated that made it stop?

I'm new to Linux and feel a little lost here, so I hope someone can help me out here.
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

redhat fedora 3

Postby crazyman » 14. June 2005 17:47

I am using RedHat FC3.
I did some upgrades recently I believe everything stopped working the 13th:

######################################################################
Jun 13 07:42:36 valence LAMPP: /opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
#####################################################################

I can't remember all the updates I did ...one of them was gamin... it is a File alteration monitor
this is a tough one for me, I will have to go back and find what was exactly upgraded and let you know ...could you do the same ...maybe we can figure this out.
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

updates

Postby crazyman » 14. June 2005 17:48

[Mon Jun 13 13:47:33 2005] up2date availablePackageList from network
[Mon Jun 13 13:48:44 2005] up2date availablePackageList from network
[Tue Jun 14 08:17:24 2005] up2date availablePackageList from network
[Tue Jun 14 08:35:51 2005] up2date installing packages: ['gamin-0.1.1-1.FC3', 'gamin-devel-0.1.1-1.FC3']
[Tue Jun 14 08:36:22 2005] up2date deleting /var/spool/up2date/gamin-0.1.1-1.FC3.i386.hdr
[Tue Jun 14 08:36:22 2005] up2date deleting /var/spool/up2date/gamin-0.1.1-1.FC3.i386.rpm
[Tue Jun 14 08:36:22 2005] up2date deleting /var/spool/up2date/gamin-devel-0.1.1-1.FC3.i386.hdr
[Tue Jun 14 08:36:22 2005] up2date deleting /var/spool/up2date/gamin-devel-0.1.1-1.FC3.i386.rpm

here is what was updated from my system logs
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

yum

Postby crazyman » 14. June 2005 17:52

Strange... I thought yum was updated as well ...did you do an up to date recently? did it upgrade yum?
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

ok one last post so someone better at this won't get tired

Postby crazyman » 14. June 2005 18:01

Here is the first error I get when xampp tries to execute:
Starting XAMPP for Linux 1.4.13...
/opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/mysql/libmysqlclient.so.14: cannot restore segment prot after reloc: Permission denied
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby kestrel_rob » 14. June 2005 19:09

How do I find out what was updated with the up date?

And yes I did one this morning Tuesday (I was off work Friday and Monday).

Oh I don't get the same error as you on start up. I just get...

XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/

I copied all my files to a different directory and re-installed the latest version of XAMPP, and that gave me the same error as you detailed in your post.

I then copied my backup over this version and that error went away, but apache still doesn't start.

I am desperate to fix this, as I need to make a presentation tomorrow!! :shock:

I think I'm doomed!! hehe
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

Postby crazyman » 14. June 2005 19:30

applications->
system tools->
system logs->
update agent log
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

rpm roll back

Postby crazyman » 14. June 2005 19:33

the only other thing I can think of doing is to do a rpm rollback for gamin just to see if gamin is to blamin LOL I'm so funny sometimes ..excuse my lude behaviour we don't have air cond.
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Postby kestrel_rob » 14. June 2005 19:34

Cheers, I'm at home now so will have to wait until the morning to be able to try it.

I will post my findings as soon as I get into work.

Cheers
kestrel_rob
 
Posts: 11
Joined: 14. June 2005 13:26
Location: Wallington - England

PHP

Postby crazyman » 14. June 2005 20:00

I'm begining to think that it is the same old Apache and PHP aren't friends deal ...try to figure out if you are running PHP5 or PHP4 I believe I am running PHP5 I'm going to try and run PHP4 instead, but I will work on this tomorrow, going home now.

Cheerio,
Eric the crazyman
crazyman
 
Posts: 13
Joined: 14. June 2005 17:05
Location: Buffalo, NY

Next

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests