xampp on damn small linux

Problems with the Linux version of XAMPP, questions, comments, and anything related.

xampp on damn small linux

Postby snipes420 » 15. May 2005 04:46

im trying to run xampp on a hard drive install of damn small linux.
i installed it as usual with the commands listed on the apachefriends website.
but when i go to start it, apache doesn't start and returns this error:
Starting XAMPP for Linux 1.4.12
XAMPP: Starting Apache with SSL (and PHP5)
XAMPP: Error 139! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

so it looks like everything starts except apache. the contents of the /opt/lampp/logs/apachestart.log are
/opt/lampp/bin/apachectl: line 100: 371 Segmentation fault $HTTPD $ARGV

if anyone can help me i would be very happy :)
thank you

Edit:: I think the problem may be, i was running damn small linux in qemu.
the XAMPPonCD does not work for me in qemu either.
thanks Kris
Posts: 11
Joined: 09. December 2004 04:12

Mysql not Running

Postby ramon » 17. May 2005 22:10

Dear fellas,

I'm also running into a similar problem, with Error 1, and xampp has no idea what's wrong.

It's a Mandrake 10 distribution, where I removed all previous independent installations of apache, mysql and php. Then, ran the xamp installation as shown in the website.

However, there are some trailing mysql folders.

The status check shows MySQL is deactivated.

Anyone with similar problems, and fixed this please respond asap..


Posts: 1
Joined: 17. May 2005 21:01

Postby Kristian Marcroft » 18. May 2005 11:09


could you please have a look in

So long
User avatar
Kristian Marcroft
AF Moderator
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Re: xampp on damn small linux

Postby Emu » 28. March 2006 09:51

snipes420 wrote:Edit:: I think the problem may be, i was running damn small linux in qemu.
the XAMPPonCD does not work for me in qemu either.
thanks Kris

Yeah, that's what I think too. I also had no success in running XAMPP within qemu, same error :-(

I could solve the problem with using accelerated qemu (kqemu).

I used a debian linux.

Emilio Paolini <ep@IM-NETZ.de>
User avatar
Posts: 6
Joined: 01. October 2004 23:29

I'm testing XAMPP-1.5.3a and PHP-Nuke on DSL-2.4

Postby hs7sv » 12. July 2006 15:12

I'm testing XAMPP-1.5.3a and PHP-Nuke on DSL-2.4
I'm using GRUB Frugal with option: home=hda3 opt=hda3.
Folder /tmp needs to be able to Read/Write for XAMPP. Then, I added the following into /opt/bootlocal.sh
Code: Select all
sudo chmod go+rw /tmp
sudo /opt/lampp/lampp start

It works but I can't see all tables when I check my database by phpmyadmin:-
nuke (95)
No tables found in database.

I can see them when I use tinyMy. That means my database is working but phpmyadmin cannot see its tables.
Can someone help me on this issue? Thanks :D

[EDIT] The problem is solved. I deleted all databases and reinstaledl it again. Now, It works! :D
User avatar
Posts: 2
Joined: 12. July 2006 14:20

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 13 guests