MySql problem. Easy solution?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

MySql problem. Easy solution?

Postby hatsoff » 10. May 2005 19:44

I get MySql deactivated when I run Lampp 1.4.13 on my Slackware 10 machine. MyPhPAdmin spits out:

#2002 - Can't connect to local MySQL server through socket '/opt/lampp/var/mysql/mysql.sock'

This is my splash screen when I boot up Lampp:

XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
/opt/lampp/lampp: line 280: /opt/lampp/var/proftpd/start.err: No such file or directory
cat: /opt/lampp/var/proftpd/start.err: No such file or directory
XAMPP:
XAMPP: Error 1! Couln't start ProFTPD!

Can it have something to do with ProFTPD not working properly?
I should mention that this same thing happens with Lampp 1.4.11, so I have tried other versions.
hatsoff
 
Posts: 3
Joined: 10. May 2005 18:32

Postby hatsoff » 10. May 2005 21:52

It was easy to solve! All I did was to extract the Lampp package with the Linux program Arch instead of opening the package in Konqueror and copying the files to /opt from there. Seems as if Konqueror isn't all that reliable when it comes to extracting files.
hatsoff
 
Posts: 3
Joined: 10. May 2005 18:32

Postby Kristian Marcroft » 11. May 2005 06:19

Hi,

you shouldn't even use the Programm Arch either!!!
Please only extract XAMPP the way it's described on our website!

There is a reason why we insist on this!
Otherwise we can't give any support!

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests