Error 2013

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 2013

Postby oldandgrey » 01. April 2005 22:20

I have just downloaded XAMPP for Linux 1.4.12 and installed it on Suse 9.1.

I loaded up some tables (no data) and tried to use the ALTER TABLE command to change them to innodb using phpMyAdmin and an SQL statement. This did not appear to have any effect so I downloaded Mysql-administrator from the mysql site (RPM), but now executing the same command in it gives -

Error executing SQL commands to update table.
MySQL Error Nr. 2013
Lost connection to MySQL server during query

Can anyone point me in the right direction.

thanks
oldandgrey
 
Posts: 4
Joined: 01. April 2005 22:10

2013

Postby oldandgrey » 01. April 2005 23:16

Reinstalled over installation and the problem went away. However now I find that phpMyAdmin only allows me heap,merge and myisam table types. What happened to the innodb?
oldandgrey
 
Posts: 4
Joined: 01. April 2005 22:10

Postby Wiedmann » 01. April 2005 23:20

What happened to the innodb?

You must enable InnoDB in the file "my.cnf":
Code: Select all
[mysqld]
#skip-innodb

(prepend a "#" in front of the line)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests