Reconfigure of PHP fails on bz2 version

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Reconfigure of PHP fails on bz2 version

Postby prowl » 22. March 2005 19:52

I am trying to reconfigure PHP because I need aspell to be installed for an application to work. When I try configuring (without aspell or with) I get the following error.

Anyone have any ideas why it would think its the wrong version? It looks to me like the correct version is installed.

Code: Select all
checking for OpenSSL support... yes
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for OpenSSL version... >= 0.9.6
checking for CRYPTO_free in -lcrypto... (cached) yes
checking for SSL_CTX_set_ssl_version in -lssl... (cached) yes
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... /opt/lampp
checking for gzgets in -lz... (cached) yes
checking whether to enable bc style precision math functions... yes
checking for BZip2 support... yes
checking for BZ2_bzerror in -lbz2... no
configure: error: bz2 module requires libbz2 >= 1.0.0


Here is the configure command I tried

Code: Select all
./configure --prefix=/opt/lampp --with-apxs2=/opt/lampp/bin/apxs --with-config-file-path=/opt/lampp/etc --with-mysql=/opt/lampp --disable-debug --enable-bcmath --enable-calendar --enable-ctype --enable-dbase --enable-discard-path --enable-exif --enable-filepro --enable-force-cgi-redirect --enable-ftp --enable-gd-imgstrttf --enable-gd-native-ttf --with-ttf --enable-magic-quotes --enable-memory-limit --enable-safe-mode --enable-shmop --enable-sigchild --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-trans-sid --enable-versioning --enable-wddx --enable-yp --with-ftp --with-gdbm=/opt/lampp --with-jpeg-dir=/opt/lampp --with-png-dir=/opt/lampp --with-tiff-dir=/opt/lampp --with-freetype-dir=/opt/lampp --without-xpm --with-zlib=yes --with-zlib-dir=/opt/lampp --with-openssl=/opt/lampp --with-expat-dir=/opt/lampp --enable-xslt --with-xslt-sablot=/opt/lampp -with-ming=/opt/lampp --with-dom=/opt/lampp --with-ldap=/opt/lampp --with-ncurses=/opt/lampp --with-gd --with-imap-dir=/opt/lampp --with-imap-ssl --with-imap=/opt/lampp --with-gettext=/opt/lampp --with-mysql-sock=/opt/lampp/var/mysql/mysql.sock --with-mcrypt=/opt/lampp --with-mhash=/opt/lampp --enable-sockets --enable-mbstring=all --with-curl=/opt/lampp --enable-mbregex --enable-zend-multibyte --with-zip=/opt/lampp --enable-exif --with-bz2=/opt/lampp


Thanks
prowl
 
Posts: 4
Joined: 22. March 2005 19:44

Postby Wiedmann » 22. March 2005 20:03

configure: error: bz2 module requires libbz2 >= 1.0.0

You have this file (libbz2.so) in your library search path?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby prowl » 22. March 2005 20:23

Here is my path

/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/amcleod/bin:/opt/lampp/lib:/usr/lib

and here is my locate

/usr/lib/libbz2.so.1
/usr/lib/libbz2.a
/usr/lib/libbz2.so
/usr/lib/libbz2.so.1.0.2
/usr/local/src/lampp/lib/libbz2.a
/opt/lampp/lib/libbz2.a

It should find it Unless I'm looking at the wrong thing. I am fairly new to linux.
prowl
 
Posts: 4
Joined: 22. March 2005 19:44


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests