Please Help!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Please Help!

Postby JohnNightwolf » 20. March 2005 21:21

I would like to set up Xampp to use my /home/nightwolf/public_html files
So basically I would like Xampp setup for Users
So instead of just http://mydomain/htdocsfolder/ it would look something like http://mydomain/~user_public_html/

I have looked into the httpd.conf and the httpd-std.conf and they are both the same are those the files I need to set this up are are there some other files I need to setup for this to work like I want it

I don't want to use up all the space in my "/ partition"
I use Mandrake linux and on my HD that I have the linux on (for I have a duleboot system)
I have two HD's one with windows and the other Linux
HD's setup
hda = C:/all my windows files | D:/for my Documents
hdb = /for all the main linux files and root files=5.8GB | swap file=1GB | /home=48GB

And with the way things are setup now with the server (the original install) I don't want the htdocs folder to eat up my "/ parition" and would rather have it look like I can host more then one user (not that I'm going to For I only have DSL)

And if any one know, is it posible for my to have the server running when I'm using the windows side of my system

Edit:
And just a note,
In the httpd.conf and the http-std I have found I think this is what I may be pertaining to here in my post

Code: Select all
#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
UserDir public_html

#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
#<Directory /home/*/public_html>
#    AllowOverride FileInfo AuthConfig Limit
#    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
#    <Limit GET POST OPTIONS PROPFIND>
#        Order allow,deny
#        Allow from all
#    </Limit>
#    <LimitExcept GET POST OPTIONS PROPFIND>
#        Order deny,allow
#        Deny from all
#    </LimitExcept>
#</Directory>

Is this where I need to edit to get what I want to work?
JohnNightwolf
 
Posts: 10
Joined: 20. March 2005 20:29

Postby JohnNightwolf » 21. March 2005 04:11

I have also noticed that all the Mod files have a .so are they supost to be like this?
JohnNightwolf
 
Posts: 10
Joined: 20. March 2005 20:29

Postby Kristian Marcroft » 21. March 2005 07:36

Hi,

yes they are supposed to have .so
It's the same as with Windows has the .dll in *nix it's .so

To get to your UserDir, yes thats exaclly what you have to change. BUt only in the httpd.conf httpd-std.conf is just for fallback. This file is ignored.

Just remove the # infront of the Lines.
Restart Apache...

Thats it

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby JohnNightwolf » 21. March 2005 14:28

OK well I have tried that and I'm still getting an Error

Forbidden

You don't have permission to access /~nightwolf on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

How can I fix this?

heres what I have now

Code: Select all
#
# UserDir: The name of the directory that is appended onto a user's home
# directory if a ~user request is received.
#
UserDir public_html

#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory /home/*/public_html>
    AllowOverride FileInfo AuthConfig Limit
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS PROPFIND>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS PROPFIND>
        Order deny,allow
        Deny from all
    </LimitExcept>
</Directory>
JohnNightwolf
 
Posts: 10
Joined: 20. March 2005 20:29

Postby JohnNightwolf » 25. March 2005 22:41

Well I was hoping to get more help!
JohnNightwolf
 
Posts: 10
Joined: 20. March 2005 20:29

Postby rickh57 » 17. March 2006 17:29

I realize that this is a year later... In order to access user/xxx/public_html, you need to change permissions on both the xxx and public_html directories to allow others to read and execute them (and therefore see them).
rickh57
 
Posts: 25
Joined: 28. April 2005 17:12


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests