mysqlhotcopy error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mysqlhotcopy error

Postby argie01 » 24. February 2005 09:45

Hello,

I'm trying to use the "mysqlhotcopy" command to do a backup of a database.
This is the command I'm running:

./mysqlhotcopy -u root -p password mysql /tmp/


and i'm getting this error:

install_driver(mysql) failed: Can't load '/opt/lampp/lib/perl5/site_perl/5.8.4/i686-linux/auto/DBD/mysql/mysql.so' for module DBD::mysql: libmysqlclient.so.12: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio at /opt/lampp/lib/perl5/5.8.4/i686-linux/DynaLoader.pm line 230.
at (eval 5) line 3
Compilation failed in require at (eval 5) line 3.
Perhaps a required shared library or dll isn't installed where expected
at ./mysqlhotcopy line 178


I'm running Xampp for linux 1.4.11
Is it a problem with this version ??

thank you !
argie01
 
Posts: 23
Joined: 19. July 2004 19:17

Postby Oswald » 24. February 2005 14:12

Dear argie01!

Yes, that's a problem with 1.4.11. The MySQL support of Perl is broken because I upgraded MySQL in that version of XAMPP without updating Perl.

Upgrade to 1.4.12 should fix this problem.

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 1 guest