Error 2002 at Login Screen

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 2002 at Login Screen

Postby Philip G. Duffy » 23. February 2005 18:38

I have successfully installed XAMPP on a Linux machine and done an opt/lampp/lampp start to start the servers, but received the following when attempting to login to phpMyAdmin:

Error 2002: Can't connect to local MySQL Server through socket '/opt/lampp/var/mysql/mysqlsock' (2)

I would not expect this message to result from a simple failed login attempt.

Have I failed to set an appropriate conguration option?
Philip G. Duffy
Philip G. Duffy
 
Posts: 21
Joined: 10. February 2005 17:55
Location: West Chester, PA, USA

Postby Oswald » 23. February 2005 19:35

Dear Philip!

Looks like your MySQL didn't came up. There are many reasons. Please take a look into the .err file in /opt/lampp/var/mysql/

Are there any error like messages at the end of this file?

Greetings
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Error 2002 at Login Screen

Postby Philip G. Duffy » 23. February 2005 23:40

Oswald,

Thanks for your guidance. I reviewed the error log and determined that in the past /opt/lampp/lampp start had consistently opened the MySQL server. Today I had an error as follows:

[ERROR] /opt/lampp/sbin/mysqld: unknown option '--Set .._log_file_size to 25% of buffer pool size' <mysql then ended>

Does this narrow the possibilities?

Phil
Philip G. Duffy
Philip G. Duffy
 
Posts: 21
Joined: 10. February 2005 17:55
Location: West Chester, PA, USA

Postby Oswald » 23. February 2005 23:48

Dear Philip!

Did you made any changes to the file /opt/lampp/etc/my.cnf?

I assume you missed a # in front of a line containing Set .._log_file_size to 25 % of buffer pool size

Best regards
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Error 2002 at Login Screen at Login Screen Solved

Postby Philip G. Duffy » 24. February 2005 02:08

Oswald,

You were on target. Mystery solved. I looked in the offending statement in etc/my.cnf and commented it. I had uncommented a series of these statements in the section which directed,

# Uncomment the following if you are using InnoDB tables.

I left the skip-inno-db statement uncommented so my Server believes that I am ready for InnoDB. Frankly I doubt that. But the important thing is that I can get to the phpMyAdmin interface.

But I may be missing an understanding of the correct setup for InnoDB if I proceed. I did not find an explanation in Delisle's Mastering phpMyAdmin (otherwise this text appears to be excellent), so I wonder how I proceed. I suspect that I should also install the Linked Tables Infrastructure to gain the full benefits of phpMyAdmin.

Vielen Dank fuer deine Hilfe.

Phil
Philip G. Duffy
Philip G. Duffy
 
Posts: 21
Joined: 10. February 2005 17:55
Location: West Chester, PA, USA

Postby Wiedmann » 24. February 2005 02:24

I left the skip-inno-db statement uncommented so my Server believes that I am ready for InnoDB.

That's right. Only uncommenting this statement "skip-inno-db" and InnoDB is running well with the standard (compiled) settings.

But I may be missing an understanding of the correct setup for InnoDB if I proceed. I did not find an explanation in...

MySQL have an excellent online manual...
http://dev.mysql.com/doc/mysql/en/innod ... ation.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Error 2002 at Login Screen

Postby Philip G. Duffy » 24. February 2005 23:43

You were right again. I had commented the skip-inno-db statement, left an audit trail, so I understand this part of the system's behavior. I checked the documentation you referenced and it all ties together. This thread should be considered successfully closed. I have an earlier thread still open, and will provide feedback as I go through the next step here.

Vielen Dank und guten Abend (if I get in under the wire as I understand German custom requires).

Phil
Philip G. Duffy
Philip G. Duffy
 
Posts: 21
Joined: 10. February 2005 17:55
Location: West Chester, PA, USA


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests