Issue with Perl DBD::mysql

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Issue with Perl DBD::mysql

Postby mrjay » 11. February 2005 21:47

XAMPP for Linux 1.4.11

[root@vex root]# ./test.pl
install_driver(mysql) failed: Can't load '/opt/lampp/lib/perl5/site_perl/5.8.4/i686-linux/auto/DBD/mysql/mysql.so' for module DBD::mysql: libmysqlclient.so.12: cannot open shared object file: No such file or directory at /opt/lampp/lib/perl5/5.8.4/i686-linux/DynaLoader.pm line 230.
at (eval 1) line 3
Compilation failed in require at (eval 1) line 3.
Perhaps a required shared library or dll isn't installed where expected
at ./test.pl line 6

#!/opt/lampp/bin/perl
use DBI;
$dbh = DBI->connect("DBI:mysql:QREF:localhost",root,mypass) ||
die "Failed to connect to MySQL. Error: $DBI::errstr\n\n"
print "OK\n";


[root@vex mysql]# ls
libmysqlclient libmysqlclient.14.0.0 libmysqlclient.so.14
libmysqlclient.14 libmysqlclient.so libmysqlclient.so.14.0.0
[root@vex mysql]# pwd
/var/lampp/lib/mysql

I'm really taking a guess here but it seems like /opt/lampp/bin/perl is looking for libmysqlclient.so.12 which is not present. Anyone had any luck using this installation of perl's mysql module? Any pointers would be appreciated.
mrjay
 
Posts: 1
Joined: 11. February 2005 20:37

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests