The Simplest Remedy is Usually the Best Remedy!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

The Simplest Remedy is Usually the Best Remedy!

Postby wb812 » 08. January 2020 10:28

I have been working on getting xampp and word press to work on my computer for the last 8 Hrs. And the fix for me was a simple one;however, it took reading posts on different forums (this one included) and watching U-Tube vids, and just keep working on figuring out how to make things work,that I missed the real problem for @ least 7-1/2 Hrs.
Finally; while trying to do everything in the terminal,(using sudo), I got the same error that everyone here seemed to be having with everything installing O.K., but, the browser problem persisted! Then I really started to pay attention to my terminal output. I was getting this
error: "Running Firefox as root in a regular user's session is not supported. ($XDG_RUNTIME_DIR is /run/user/1000 which is owned by woody)."
The same error I was getting when installing within the GUI (only not as verbose!). So! I did the dangerous fix! I logged out of the std. user account, and logged into the root user account, and performed everything according to the install instructions I read and everything went with no problems. I installed Word Press and, viola, there it was! I then logged out of the root acct. and logged back into my regular account and was able to see the Word Press web page. Simple, Heh??

[code]
System: Host: The-Punisher-MX Kernel: 4.19.0-5-amd64 x86_64 bits: 64 compiler: gcc v: 6.3.0
Desktop: Xfce 4.12.3 Distro: MX-18.3_x64 Continuum May 26 2019
base: Debian GNU/Linux 9 (stretch)
Machine: Type: Desktop System: ASUS product: All Series v: N/A serial: <filter>
Mobo: ASUSTeK model: X99-DELUXE II v: Rev 1.xx serial: <filter>
UEFI [Legacy]: American Megatrends v: 1902 date: 04/19/2018
Battery: Device-1: hidpp_battery_0 model: Logitech K520 charge: High status: Discharging
Device-2: hidpp_battery_1 model: Logitech Wireless Mouse charge: Normal
status: Discharging
CPU: Topology: 6-Core model: Intel Core i7-5820K bits: 64 type: MT MCP arch: Haswell
rev: 2 L2 cache: 15.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 79203
Speed: 1393 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1202
4: 1399 5: 1200 6: 1200 7: 1201 8: 1300 9: 1201 10: 1200 11: 1200 12: 1201
Graphics: Device-1: AMD Ellesmere [Radeon RX 470/480] vendor: ASUSTeK driver: amdgpu v: kernel
bus ID: 01:00.0
Display: x11 server: X.Org 1.19.2 driver: amdgpu,ati
unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~60Hz
OpenGL:
renderer: AMD Radeon RX 480 Graphics (POLARIS10 DRM 3.27.0 4.19.0-5-amd64 LLVM 7.0.0)
v: 4.5 Mesa 18.2.6 direct render: Yes
Audio: Device-1: Intel C610/X99 series HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel bus ID: 00:1b.0
Device-2: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1
Sound Server: ALSA v: k4.19.0-5-amd64
Network: Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000
bus ID: 00:19.0
IF: eth1 state: down mac: <filter>
Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.4.0-k
port: d000 bus ID: 0b:00.0
IF: eth0 state: down mac: <filter>
Device-3: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter vendor: ASUSTeK
driver: wl v: kernel port: d000 bus ID: 0d:00.0
IF: wlan0 state: up mac: <filter>
Drives: Local Storage: total: 9.10 TiB used: 311.80 GiB (3.3%)
ID-1: /dev/sda vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB temp: 29 C
ID-2: /dev/sdb type: USB vendor: Seagate model: Desktop size: 7.28 TiB
Partition: ID-1: / size: 105.86 GiB used: 10.06 GiB (9.5%) fs: ext4 dev: /dev/sda1
ID-2: /home size: 1.63 TiB used: 301.74 GiB (18.1%) fs: ext4 dev: /dev/sda2
ID-3: swap-1 size: 56.27 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3

Sincerely: wb812 :oops:
wb812
 
Posts: 1
Joined: 08. January 2020 09:44
XAMPP version: 7.4.1.0
Operating System: MX-Linux 18.3 Continuum

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests