Imagick, xampp, ubuntu 18.04, tears

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Imagick, xampp, ubuntu 18.04, tears

Postby Agroprom » 09. October 2018 17:34

Hi all. I know this question was asked plenty of times but here we are again... :)

I was trying to intsall Imagick extension to my xampp according to this guide https://community.apachefriends.org/viewtopic.php?f=17&t=76417&hilit=imagick
Everything seemed to be fine, but unfortunately the last step doesn't work. In my php_error.log I have the following:

[09-Oct-2018 16:19:28 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/lampp/lib/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/x86_64-linux-gnu/libpng16.so.16) in Unknown on line 0
Agroprom
 
Posts: 3
Joined: 09. October 2018 17:23
XAMPP version: 7.1.22
Operating System: Ubuntu 18.04

Re: Imagick, xampp, ubuntu 18.04, tears

Postby Agroprom » 11. October 2018 16:59

Simse like the situation got a little more clear. The first problem was with ZLIB_1.2.9. I installed it to /opt/lampp and that problem dissapeared.
New problem is "[11-Oct-2018 15:57:23 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/lampp/lib/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /usr/lib/x86_64-linux-gnu/libdjvulibre.so.21) in Unknown on line 0"

Seems like I need to install libstdc++.so.6.
Agroprom
 
Posts: 3
Joined: 09. October 2018 17:23
XAMPP version: 7.1.22
Operating System: Ubuntu 18.04

Re: Imagick, xampp, ubuntu 18.04, tears

Postby Agroprom » 11. October 2018 17:29

Yes, after coping libstdc++.so.6 to /opt/lampp/lib it works.
Agroprom
 
Posts: 3
Joined: 09. October 2018 17:23
XAMPP version: 7.1.22
Operating System: Ubuntu 18.04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests