Failed to Execute default Web Browser- input/output error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Failed to Execute default Web Browser- input/output error

Postby zeuqsav » 06. February 2018 00:41

Ubuntu 17.4
Xampp 7.2.1

Installed and ran the following in terminal: sudo ./manager-linux-x64.run
Graphic interface appears, and when I try to launch Go To Application I get the following small window message "Failed to Execute default Web Browser- input/output error" and in terminal I see this:
[3987:3987:0205/153738.562928:ERROR:zygote_host_impl_linux.cc(90)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

I tried changing my default web browsers, to no avail.
zeuqsav
 
Posts: 1
Joined: 06. February 2018 00:31
XAMPP version: 7.2.1
Operating System: Ubuntu Studio 17.4

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 12. February 2018 12:30

I have the same problem. Exactly.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Nobbie » 12. February 2018 17:01

Enter the message "Failed to Execute default Web Browser- input/output error" into Google and you will see, that this is a bug of Chromium and Chrome browser. Change the default browser in your environment or try to download an updatet version of Chrome or Chromium (if there is a newer version).

zeuqsav wrote:I tried changing my default web browsers, to no avail.


How did you try and which one is default now? And did you restart Ubuntu?
Nobbie
 
Posts: 9993
Joined: 09. March 2008 13:04

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 12. February 2018 19:30

I googled and I have seen that post. I changed with "Preferred Applications" my preferred webbrowser to Opera. That didn't work. I fired Xubuntu up again and it still didn't work.
It isn't simply a browser problem.
P.s.: I don't have Chrome or Chromium installed.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Nobbie » 12. February 2018 22:10

It is a browser problem and it is Chromium Problem. Dont know what you are doing wrong and if you have fragments of wrong installation, but this ist the mentioned source file zygote_host_impl_linux.cc:


https://code.woboq.org/qt5/qtwebengine/ ... ux.cc.html

It is part of Chromium Browser source code.
Nobbie
 
Posts: 9993
Joined: 09. March 2008 13:04

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 12. February 2018 22:34

Sorry, it is not. I hadn't Google Chrome installed nor Chromium. I installed both of them now and started playing with the defaults with the commandline:
sudo update-alternatives --config x-www-browser
I made firefox and then opera the default. It didn't work. It doesn't work with any browser set to default.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Nobbie » 13. February 2018 10:44

You applied that error message from zygote_host_impl_linux.cc and not me (resp. you said that you have EXACTLY the same error). And that module is very very clearly from chromium, as you can see in the source code. Thats all i know about your machine, everything else is on you. Also the provided link httpd://crbugs.com points to chromium.
Nobbie
 
Posts: 9993
Joined: 09. March 2008 13:04

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 13. February 2018 14:30

I have to admit something: I HATE google chrome and chromium. I haven't installed these browsers on any of my systems. So, what did I do:
I installed in Virtualbox Xubuntu. I installed the browser Opera and everything works fine.
I installed Lampp and got it to work. Then I installed Bitnami Wordpress. Now it stopped working. I deinstalled with the uninstaller Bitnami Wordpress. It still doesn't work well. I searched on the internet for any answers and yes, I found chromium mentioned as the culprit. Which is weird because I hadn't touched it all.
Yes, the error message is EXACTLY what the original poster posted. I don't know why the error message points to chromium. It could be flagged wrongly.
So, this is what I am going to do: I am going to deinstall lampp and reinstall it.
Thank you for your answers.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 13. February 2018 15:28

I deinstalled Lampp (I cleared the /opt/ folder) and I try to install it, again, into the /opt/ folder. And during the install I get the same error message.
Opera is my default webbrowser.

I deinstalled Opera and Firefox is my only webbrowser now. No problems during installation. Everything works now.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Nobbie » 13. February 2018 19:33

Da wir die Einzigen hier sind, können wir auch Deutsch schreiben. Ich habe hier Linux Mint 18.3 momentan installiert (manchmal auch Manjaro, aber im Moment Mint) und finde Chrome und Chromium beide sehr gut (es gibt für mich sowieso nur einen schlechten Browser und das ist IE bzw. jetzt Edge) und bei mir läuft die Xampp Installation auch. Ich habe zwar auch Firefox und Opera installiert, aber Default ist Chromium. Finde ich übrigens vom Druckdialog mit Abstand den besten Browser, wobei Opera das Interface mittlerweile frech abgekupfert hat.

Irgendwo habe ich gelesen, dass ggf. auch Teile von Chromium im "Docker"(kenne ich nicht ist wahrscheinlich eines der vielen Docks unter Linux) verwendet werden und von dort aus den gleichen Fehler erzeugen. Vielleicht deswegen?? Bei mir läuft es einfach auch so.
Nobbie
 
Posts: 9993
Joined: 09. March 2008 13:04

Re: Failed to Execute default Web Browser- input/output erro

Postby Kraueter19 » 13. February 2018 21:19

Es macht mir spaß daß Sie denken das ich Deutscher bin. Keinesfalls. Obschon ich in Deutschland geboren worden bin. Aber ich bin Niederländer. Ich verstehe wie mache Niederländer die Deutsche Sprache schon gut. Danke für ihre Antworte.
Kraueter19
 
Posts: 6
Joined: 12. February 2018 12:28
XAMPP version: 7.2..1-0
Operating System: Ubuntu

Re: Failed to Execute default Web Browser- input/output erro

Postby Nobbie » 13. February 2018 21:38

Kraueter19 wrote:Es macht mir spaß daß Sie denken das ich Deutscher bin. Keinesfalls. Obschon ich in Deutschland geboren worden bin. Aber ich bin Niederländer. Ich verstehe wie mache Niederländer die Deutsche Sprache schon gut. Danke für ihre Antworte.


Der Name sieht so deutsch aus. Im Gegenzug verstehe ich sehr gut niederländisch, ich habe ein Haus in Zeeland und fahre seit vielen Jahren nach Holland in den Urlaub. Sowieso wohne ich auch nicht weit weg von der holländischen Grenze, ich wohne in Mönchengladbach. Meine Mutter hieß mit Nachnamen "van der Bent", aber ich bin Deutscher.
Nobbie
 
Posts: 9993
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 1 guest