Trying to install xampp on Ubuntu gives error

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Trying to install xampp on Ubuntu gives error

Postby KhmerKerry » 06. June 2017 06:20

I am trying to install xampp 5.6.30 on Ubuntu 16.04. I have read and tried the instructions.

Code: Select all
chmod xampp-linux-x64-5.6.30-1-installer.run

gives error
Code: Select all
chmod: cannot access 'xampp-linux-x64-5.6.30-1-installer.run': No such file or directory

so I changed to Downloads directory and command seems to run
I have checked the file in downloads and it exists. But
Code: Select all
sudo xampp-linux-x64-5.6.30-1-installer.run

still gives error
Code: Select all
sudo: xampp-linux-x64-5.6.30-1-installer.run: command not found

even when run from the Downloads directory

I can double click the file in the Downloads folder, the Bitnami splash screen displays and then it tells me
There has been an error. This installer requires root privileges. Please become a superuser before executing installer
KhmerKerry
 
Posts: 2
Joined: 06. June 2017 05:48
XAMPP version: 5.6.30
Operating System: Ubuntu 16.04

Re: Trying to install xampp on Ubuntu gives error

Postby Nobbie » 06. June 2017 10:46

KhmerKerry wrote:I have read and tried the instructions.


You have not read carefully:

Code: Select all
sudo xampp-linux-x64-5.6.30-1-installer.run


That is the wrong syntax. The correct syntax (as shown in the instructions) is:

Code: Select all
sudo ./xampp-linux-x64-5.6.30-1-installer.run


Do you see the difference?
Nobbie
 
Posts: 9763
Joined: 09. March 2008 13:04

Re: Trying to install xampp on Ubuntu gives error

Postby KhmerKerry » 07. June 2017 05:30

yeah I see the difference. I thought because I was in the Downloads folder I did not need ./ sorry - but dude - I spent hours on this and you solved it in minutes - thank you so much - my bad - do you have any idea how I can log in again as root without ubuntu expecting root program instead of root command - thanks - you are a star
KhmerKerry
 
Posts: 2
Joined: 06. June 2017 05:48
XAMPP version: 5.6.30
Operating System: Ubuntu 16.04

Re: Trying to install xampp on Ubuntu gives error

Postby Nobbie » 07. June 2017 09:13

First use "sudo" in order to change to root UserId:

Code: Select all
sudo su


Then you are root User. If you like to login as User (instead of cirumvent via sudo su), provide a password for root User, enter "passwd" (after you did "sudo su") and then provide a password of your choice. After you have finished, you can login with root and that password.

P.S.:
KhmerKerry wrote:I thought because I was in the Downloads folder I did not need ./


Thats wrong. Linux is NOT Windows (on Windows it would work). On Linux the shell can execute a program without a folder prefixed, only if your current folder is part of the PATH Variable. Do an "echo $PATH" in a shell to see the value of your PATH variable. You will see, that neither your Download folder nor "." if part of the PATH. If you want, you may extend your PATH variable to contain the "." (you can do that either in your local .rc file or the bash/sh specific startup file, or in the system wide /etc/rc etc.). In a real multiuser environment this may cause some bad security issues (therefore the dot "." is not included in the PATH variable), but i think you are running a single user environmen, so that is not an issue.
Nobbie
 
Posts: 9763
Joined: 09. March 2008 13:04

Re: Trying to install xampp on Ubuntu gives error

Postby chalancito » 29. August 2017 18:27

Hello,
I've just downloaded the xampp-linux-x64-7.1.8-0-installer.run on my Ubuntu 14.04 device.
(I change to the "Downloads" folder, I think it does not matter if I work there, instead of moving the installer to another folder)
After the permissions (chmod 755 xampp-linux-x64-7.1.8-0-installer.run), when I try to run it (sudo ./xampp-linux-x64-7.1.8-0-installer.run), after the corresponding password, I get this error message:
./xampp-linux-x64-7.1.8-0-installer.run: 1: ./xampp-linux-x64-7.1.8-0-installer.run: Syntax error: Unterminated quoted string
Oops. How can this be fixed?
Thanks in advance for the support.
chalancito
 
Posts: 2
Joined: 29. August 2017 17:47
XAMPP version: linux-x64-7.1.8-0
Operating System: Ubuntu 14.04

Re: Trying to install xampp on Ubuntu gives error

Postby Nobbie » 30. August 2017 09:31

chalancito wrote:./xampp-linux-x64-7.1.8-0-installer.run: 1: ./xampp-linux-x64-7.1.8-0-installer.run: Syntax error: Unterminated quoted string


This is the typical error message if you try to run a 64bit installer in a 32bit environment. You probably have Ubuntu 32bit installed. Unfortunately, there is no 32bit Xampp Linux version anymore (has been deprecated a couple of months ago). You must run an 64bit Linux in order to install Xampp.
Nobbie
 
Posts: 9763
Joined: 09. March 2008 13:04

Re: Trying to install xampp on Ubuntu gives error

Postby bravo5 » 26. September 2017 03:03

Hi,
I trying to install the XAMPP 7.1.9 / PHP 7.1.9 onto a IBM power system machine, machine type = 8247-42L, running Ubuntu 16.04.
I got this error too :-
sudo ./xampp-linux-x64-7.1.9-0-installer.run
[sudo] password for ibm:
./xampp-linux-x64-7.1.9-0-installer.run: 1: ./xampp-linux-x64-7.1.9-0-installer.run: Syntax error: Unterminated quoted string

I check the operation system:-
uname -a
Linux localhost 4.4.0-62-generic #83-Ubuntu SMP Wed Jan 18 14:09:19 UTC 2017 ppc64le ppc64le ppc64le GNU/Linux

Its running at 64bits.

Is XAMPP supported in power system ? If yes, can anyone let me know how to fix it ?
Thanks for reading.
bravo5
 
Posts: 2
Joined: 26. September 2017 02:52
XAMPP version: 7.1.9
Operating System: Ubuntu 16.04

Re: Trying to install xampp on Ubuntu gives error

Postby chalancito » 27. September 2017 00:26

Oops, I see the issue. I'll try to get authorization to install a 64 bits version of the OS on this device, meanwhile I'll try to build an equivalent environment. Some tips about it?.
chalancito
 
Posts: 2
Joined: 29. August 2017 17:47
XAMPP version: linux-x64-7.1.8-0
Operating System: Ubuntu 14.04

Re: Trying to install xampp on Ubuntu gives error

Postby Nobbie » 27. September 2017 08:17

bravo5 wrote:Is XAMPP supported in power system ?


No. Intel/AMD 64 only.
Nobbie
 
Posts: 9763
Joined: 09. March 2008 13:04

Re: Trying to install xampp on Ubuntu gives error

Postby bravo5 » 27. September 2017 10:05

Thanks Nobbie, Will try on LAMP....
bravo5
 
Posts: 2
Joined: 26. September 2017 02:52
XAMPP version: 7.1.9
Operating System: Ubuntu 16.04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests