Live webserver?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Live webserver?

Postby keepsedge » 23. January 2005 23:35

Playing with XAMPP i am very pleased with the program... except for a few small issues.

1.) For local website testing, XAMPP has been pretty good at what I need done. However, no matter what browser I use, I find that some of my images, dont load properly. This effect is worse with I.E.

2.) Is there a way I can use XAMPP to use my PC as a Live Webserver. so if you go to HTTP://[my IP addy] you'll get the site Im hosting.

This works well in my network, from the other PC if you go to http://myip, you'll get the site, however, from another PC on the net but not in my network. you get a 404 error, or a timeout alert.

3.) The MySQL database included with XAMPP doesnt alow me to query the database... well it does, but it complains about syntax erros. I know the syntax is good, iv'e tried it on other MySQL databases. Is it that the DB is an older version, and needs to be upgraded.. and is that possable with XAMPP.. and how.

I thanks all of you reading for your time, I'm sure I wouldn't be asking theese questions if I could read and understand German, as this has probobly been addressed already somewhere in the forums.

Thanks again all,
</keeper>
keepsedge
 
Posts: 33
Joined: 24. December 2004 11:04

Postby keepsedge » 02. February 2005 18:21

i guess no one knows
heh
keepsedge
 
Posts: 33
Joined: 24. December 2004 11:04

Re: Live webserver?

Postby Dave_L » 02. February 2005 19:09

keepsedge wrote:3.) The MySQL database included with XAMPP doesnt alow me to query the database... well it does, but it complains about syntax erros. I know the syntax is good, iv'e tried it on other MySQL databases. Is it that the DB is an older version, and needs to be upgraded.. and is that possable with XAMPP.. and how.


Which version of XAMPP and MySQL do you have installed? Could you provide an example of a query that fails, and include the complete error message?
User avatar
Dave_L
 
Posts: 212
Joined: 23. October 2004 00:43

Postby forethought » 04. February 2005 22:30

For #2. are you behind a firewall and/or router? Is the IP address you use on the machine running XAMPP 192.168.x.x?

If so then your firewall and/or router will have to be configured properly.

I distinctly remember there being a fix for the issue of images not showing up, just search the forums.

And for the MySQL problem, post the version of XAMPP your using and the commands you're trying to use.
forethought
 
Posts: 6
Joined: 09. August 2004 23:44
XAMPP Version: 1.8.3-2
Operating System: OS X 10.7.2

Postby keepsedge » 05. February 2005 13:29

no firewall, no router,

I'll come up with the errors in a bit, i am in the middle of reinstalling everything on my hardrive.. love those hackers and lovely programs who waste their talents building viruses.

XAMPP for Windows Version 1.4.11 or so it says.
MySQL 4.1.8 running on localhost,
php is switched to 4x.

Im not sure what the comands are right now, I'll have to get them.. i know they are from the mods I tried to install for the phpBB forums Im hosting. Like Xore's Cash Mod and things of the like.


</keeper>
keepsedge
 
Posts: 33
Joined: 24. December 2004 11:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests