cannot stop xampp properly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cannot stop xampp properly

Postby Kroesss » 17. January 2005 00:07

Hello,

I've installed Xampp 1.4.11 from zore up because I had problems after running the update. I cleaned mysql (deleted databases, exept for mysql and phpmyadmin, and deleted users exept root).

When I try to stop Xampp however, it claims to have no permission to stop the mysql. it states:
Code: Select all
mysql\bin\mysqladmin.exe: shutdown failed; error: 'Access denied; you need the SHUTDOWN privilage for this operation'


The rest shuts down, but the mysql doesn't. Did I delete a user I shouldn't have deleted? And if so, what are the properties for that user, so I can create it again.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Wiedmann » 17. January 2005 00:11

and deleted users exept root).

There is an other important user: pma
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kroesss » 17. January 2005 08:31

I have deleted that one indeed, can I re-create it? What are the settings for that user?
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen

Postby Wiedmann » 17. January 2005 12:56

Code: Select all
GRANT USAGE ON mysql.* TO 'pma'@'localhost';
GRANT SELECT (
    Host, User, Select_priv, Insert_priv, Update_priv, Delete_priv,
    Create_priv, Drop_priv, Reload_priv, Shutdown_priv, Process_priv,
    File_priv, Grant_priv, References_priv, Index_priv, Alter_priv,
    Show_db_priv, Super_priv, Create_tmp_table_priv, Lock_tables_priv,
    Execute_priv, Repl_slave_priv, Repl_client_priv
    ) ON mysql.user TO 'pma'@'localhost';
GRANT SELECT ON mysql.db TO 'pma'@'localhost';
GRANT SELECT ON mysql.host TO 'pma'@'localhost';
GRANT SELECT (Host, Db, User, Table_name, Table_priv, Column_priv)
    ON mysql.tables_priv TO 'pma'@'localhost';
GRANT SELECT, INSERT, UPDATE, DELETE ON phpmyadmin.* TO 'pma'@'localhost';
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Kroesss » 17. January 2005 19:08

Thanks, after running your sql, the problem was almost solved. I just needed to grant the SHUTDOWN-privilage to the pma-user, just like the error-meesage said.

Everything is working properly again.
Kroesss
 
Posts: 35
Joined: 18. November 2004 09:08
Location: Vriezenveen


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 34 guests