Apache port problem - a solution (for me)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache port problem - a solution (for me)

Postby simonwheatley » 23. December 2004 11:49

Hi

Been banging my head on this problem for several weeks, and now it's solved I thought I'd share the solution!

One reason Apache won't start is because it can't listen to port 80; i.e. something currently installed is using that port already. Don't assume that whatever was using port 80 is a web server! Download fport, follow the instructions to run it. Look down the list is provides until you find port 80, and make a note of the program/path; this listener is what you need to disable to get Apache to install.

In my case it was Skype, which by default has "listen to port 80 as an alternative" checked in the advanced options. In your case... who knows.

Good luck

Simon
simonwheatley
 
Posts: 1
Joined: 23. December 2004 11:38

well done!

Postby chanio » 27. December 2004 04:22

:lol: Hey,
It works!
Another alternative , might be to uninstall the offending software, then install Xampp and finally, re-install the program again, to see what it does when it finds that its normal port is being used by other program. Normally, it should search for another port, and then use that one.
Gallactic Firewall
User avatar
chanio
 
Posts: 72
Joined: 18. March 2003 22:05
Location: Argentina


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests