XAMPP Apache CPU 100%

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Apache CPU 100%

Postby NelsonN » 02. December 2004 00:07

I have installed XAMPP 1.4.9 and the Perl add-on on a fresh install of Windows XP SP2 with the SP2 firewall disabled.

I have noticed a problem with Mozilla 1.7 and Firefox 1.0, not with IE6.

I have a MySQL database running as a test, when I browse this database with PHPMyAdmin and then browse over to another website, like http://www.google.com, and then hit the back button, I get the postdata window and when I click on OK and go back to the PHPMyAdmin page it hangs waiting for data. When I look at the Apache service with task manager I see that Apache is running at 100%, it runs for several minutes.

Any ideas what could be causing this?

I also notice that when I start up Apache, the Apache service also runs at 100% for several minutes. I have read that this is due to the Perl add-on.

Any helpful insight appreciated.
NelsonN
 
Posts: 4
Joined: 01. December 2004 16:24

Postby Dave_L » 02. December 2004 02:08

If you don't need mod_perl, you can disable it. That makes Apache load a lot faster.

A couple of methods for doing this are described here: http://community.apachefriends.org/f/viewtopic.php?t=8176
User avatar
Dave_L
 
Posts: 212
Joined: 23. October 2004 00:43

Postby NelsonN » 02. December 2004 03:40

Thanks! :D

Turning off mod_perl fixed both the startup and the PHPMyAdmin CPU hogging problem.
NelsonN
 
Posts: 4
Joined: 01. December 2004 16:24


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests