Still having Problems with Mercury, Can SomeOne Help me??

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Still having Problems with Mercury, Can SomeOne Help me??

Postby T-Shot » 29. November 2004 18:48

OK,..

So i have installed PHPBB on my server.
Now i want to use Mercury mail server to be able to let people send mail to eachother. Now i got the onboard private messages fixed, so no problem their every mail send to a person on the board is succesfully deliverd at there account.

But i want to be able to send mail to their private addresses to.
For example, i cant send confirmation emails of accounts, cause it wont work.

Can someone tell me what i am doing wrong?

INFO:

ERROR:
Processing job MO000008
Temporary error 249 (temporary MX resolution error) resolving 'planet.nl'

(planet.nl is coming from the email i send to: s.tips@planet.nl)

PHPBB:
Use SMTP Server for email = yes
SMTP Server Address = localhost
SMTP Username = (meaning it's blank)
SMTP password =

Mercurymail server:

MercuryS SMTP Server:
Announce myself as = tippie
TCP/IP timeout = 30 seconds
ESMTP maximum size = 0 bytes
Listen on TCP/IP port = 25 alternate port = 0
IP Interface to use =
sender kill file =

checked: Display session progress and debugging information
rest unchecked.

Second tab: Connection Control:
Added an ip address 127.0.0.1 allow

Checked: Do not permit SMTP relaying of non-local mail


Does anyone know what to do?
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Re: Still having Problems with Mercury, Can SomeOne Help me?

Postby taustin » 29. November 2004 20:40

The error message you're getting says that Windows can't find the MX record to send the message to, in a way that looks temporary. My first thought is that the DNS settings are somehow messed up.

Assuming you're on XP, go to the Start Menu, and go to Control Panel.

From there, go to Network and Internet Connections or Network Connections (if you don't see the Network and Internet Connections, there should be a way to go straight to Network Connections.)

You should see something like "Local Area Connection." Right click on that, and go to Properties.

Double click on "Internet Protocol (TCP/IP)".

Towards the bottom, there should be two DNS server entries. If there are, let me know what they are. If there aren't, close all that, and go back to the Start menu.

Click on Run, and type in "cmd" (without the quotes) in the box, and hit Enter.

This should produce a black DOS box. Type in

ipconfig /all

and it should produce some info on the screen. Towards the bottom, it will list the DNS servers (probably two). Let me know what those are.

If you're not running XP, let me know what version of Windows you're using.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 29. November 2004 22:21

only one DNS server IP: 192.168.2.1

Thats the ip of my router, wich my adsl is connected to too.
What do i need to alter??

--------------------------

I went in my router and saw a link DNS.
I went to my provider homepage, found DNS ip and filled in the 2 DNS addresses.

Nothing....
i cant even receive my own mail now...
putting it back to 0.0.0.0.0 now...

Hope you can help me a bit further.
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 29. November 2004 23:12

T-Shot wrote:only one DNS server IP: 192.168.2.1


That's definitely the problem. Something in the router isn't doing DNS requests correctly, apparently. It might be that your ISP has configured it in such a way as to keep you from sending email out directly as an anti-spam measure.

The easiest fix would probably be to install MercuryC, and relay through your ISP's mail server. (To try this, go to the Configuration menu, and go to Protocol Modules, and check the box next to "MercuryC SMTP relaying client". Then restart Mercury, and you can configure it under the Configuration menu.)

You can also try fooling around with the DNS settings, and see if maybe there was a typo the first time around. If that still doesn't work, your best bet is to call your ISP and ask them if they're blocking DNS queries or outgoing SMTP. If they are, and aren't willing to unblock for you, you'll have to use MercuryC.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 30. November 2004 18:03

K, thanx for all your help so far, i really appreciate it!!

I filled in the blanks at configuration page, but when i send an email now,
i get a blank page..... :(
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 30. November 2004 18:39

T-Shot wrote:K, thanx for all your help so far, i really appreciate it!!

I filled in the blanks at configuration page, but when i send an email now,
i get a blank page..... :(


Filled in the blanks on which configuration page?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 01. December 2004 00:56

In
MercuryC SMTP Client.
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 01. December 2004 01:22

T-Shot wrote:In
MercuryC SMTP Client.


Smart host name is the same as the SMTP server name in your email settings. That's the mail server your ISP has for you to send email out through.

Announce myself as can probably be blank (it will use the internet name you put in when you installed Mercury originally).

Does your ISP require you to use a username and password to send email?

And last, towards the bottom, there's a General section. Under General Log File, enter a full path and file name for the log file, if there isn't one already. If you're using the Mercury that comes with Xampp, it should be

C:\apachefriends\xampp\MercuryMail\Logs\SMTP~Y-~M-~D.LOG

(This will create a new log each day, with the date as part of the file name, in the form of SMTP2004-11-30.log)

If you downloaded Mercury direct from pmail.com, put in

C:\MERCURY\Logs\SMTP~Y-~M-~D.LOG

(unless you changed the install directory.)

Under that, there is another box for the Session Log Directory. Put

C:\apachefriends\xampp\MercuryMail\Logs\

or

C:\MERCURY\Logs\

and check the check box that says Enable session logging.

Now, try to send a message.

If you look in the log directory, you'll see a .log file, and another file that should end with .ms. The .ms file is the session log, and has everything that happened while you tried to send the message. You can open it in Notepad, and should be able to copy & paste the contents here. That should tell us what's happening.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 01. December 2004 18:14

Planet is my internet provider,

so i put in mail.planet.nl
with name and pass i got from them, so that should work.

I filled in the log file part exaclty as you said, but problem is,
it doesnt log.
It's because when i send a mail to someone (through forum) and click
send, it loads a blank page all white....

I am freakin out here, grrrrr
Why doesnt anything work instantly with me.. :(
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 01. December 2004 18:43

If it's not generating a lot at all, then something is keeping Mercury from running correctly.

Are you using the Mercury that came with Xampp?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 01. December 2004 23:21

Yeah i do...

Only file there is: MERCURYS.LOG
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 01. December 2004 23:41

T-Shot wrote:Yeah i do...

Only file there is: MERCURYS.LOG


What's in it?
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 02. December 2004 15:56

Last part of the log: (i think its the priv messages it sends on boards)



T 20041130 093914 41aba2c7 Connection from 127.0.0.1
T 20041130 093914 41aba2c7 HELO neo
T 20041130 093914 41aba2c7 MAIL FROM:<postmaster@localhost>
T 20041130 093914 41aba2c7 RCPT TO:<ikkuh_markjones@hotmail.com>
T 20041130 093914 41aba2c7 DATA - 23 lines, 894 bytes.
T 20041130 093914 41aba2c7 QUIT
T 20041130 093914 41aba2c7 Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20041130 093914 41aba2c8 Connection from 127.0.0.1
T 20041130 093914 41aba2c8 HELO neo
T 20041130 093914 41aba2c8 MAIL FROM:<postmaster@localhost>
T 20041130 093914 41aba2c8 RCPT TO:<s.tips@planet.nl>
T 20041130 093914 41aba2c8 DATA - 23 lines, 680 bytes.
T 20041130 093914 41aba2c8 QUIT
T 20041130 093914 41aba2c8 Connection closed with 127.0.0.1, 0 sec. elapsed.
T 20041201 100616 41acb455 Connection from 212.84.133.1
T 20041201 100616 41acb455 USER anonymous
T 20041201 100616 41acb455 Connection closed with 212.84.133.1, 0 sec. elapsed.
T 20041201 131049 41acb456 Connection from 212.84.133.1
T 20041201 131049 41acb456 USER anonymous
T 20041201 131050 41acb456 Connection closed with 212.84.133.1, 1 sec. elapsed.
T 20041201 153556 41acb457 Connection from 212.84.133.1
T 20041201 153556 41acb457 USER anonymous
T 20041201 153556 41acb457 Connection closed with 212.84.133.1, 0 sec. elapsed.
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 02. December 2004 18:57

The first part is Apache/PHP connecting to Mercury, and sending a 23 line message to ikkuh_markjones@hotmail.com and s.tips@planet.nl. These look like they're accepted OK.

The last part is a connection from 212.84.133.1, which belongs to solcon.nl, and does not seem to be speaking SMTP. It then disconnects immediately.

Are you sure your ISP requires a user name and password for _outgoing_ email? Most restrict by IP address. Try blanking those out and see what happens.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 02. December 2004 20:23

Nope, still blank page, even if i blank out the username and pasw..

oh well, quess it's not meant to work for me..
Thanx for all your help taustin, i really appreciate it!!
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests