script can't read write file

Problems with the Windows version of XAMPP, questions, comments, and anything related.

script can't read write file

Postby bas456 » 28. November 2004 17:56

Recently I installed xampplite-win32-1.4.9 to test/run my website locally on my PC. I run XP PRO, NTFS (and of course xampplite).

Now I downloaded a script for search on my website.
The script is:
CJ Website Search V1.0
http://www.scriptsearch.com/cgi-bin/jump.cgi?ID=7877

Now the script gives an error:
# Warning: filesize() [function.filesize]: stat failed for /localhost/ORv1.0/search/site.dat in C:\xampplite\htdocs\ORv1.0\search\admin.php on line 410

Warning: fread(): supplied argument is not a valid stream resource in C:\xampplite\htdocs\ORv1.0\search\admin.php on line 410
Stats/Test Database

# Database State = Not Writable, CHMOD "site.dat"!
# Database Size =
Warning: filesize() [function.filesize]: stat failed for /localhost/ORv1.0/search/site.dat in C:\xampplite\htdocs\ORv1.0\search\admin.php on line 429
Bytes
# Website Count = 1

The script makes the check:
<?
if(is_writable($filename)
?>
And it seems the answer is false. How come?

It seems there is no read/write access to the file site.dat.
But: in NTFS all users have FULL CONTROL over all files.
In other forums people advised me to check if apache/php makes this problem.

Should I change something in apache/php (xampp) to make this script run?
bas456
 
Posts: 4
Joined: 28. November 2004 17:42

Postby Wiedmann » 28. November 2004 18:22

Warning: filesize() [function.filesize]: stat failed for /localhost/ORv1.0/search/site.dat in C:\xampplite\htdocs\ORv1.0\search\admin.php on line 410

The function search for the wrong file. See the different paths...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bas456 » 28. November 2004 19:20

Wiedmann wrote:
Warning: filesize() [function.filesize]: stat failed for /localhost/ORv1.0/search/site.dat in C:\xampplite\htdocs\ORv1.0\search\admin.php on line 410

The function search for the wrong file. See the different paths...


You are right. Somehow in the config.php you have to enter:
C:xampplite\htdocs\ORv1.0\search
Instead of:
http://localhost/ORv1.0/search

However xampp is running so http://localhost/ORv1.0/search/site.dat should be a valid url. Strange...
bas456
 
Posts: 4
Joined: 28. November 2004 17:42


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests