Connecting via mysqlcc

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Connecting via mysqlcc

Postby rcarabelli » 23. November 2004 18:59

I installed the new XAMPP with the windows autoinstaller.
It worked fine... GREAT really. but now I cant connect to the database using mysqlcc from a different computer in the network.
I can connect if I am in the server but cant if I am on another workstation.
What I have to configure?
Thanx
ME!!!
rcarabelli
 
Posts: 3
Joined: 23. November 2004 18:35

Postby Wiedmann » 23. November 2004 19:18

Which user did you use to connect?

What's the exact error message?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rcarabelli » 23. November 2004 19:43

I connect with local network IP 192.168.1.4 to the server so host is 192.168.1.4
using MYSQL control center (mysqlcc)
user "root"
no password
(then I created more users with and without password and failed also)

the error using user "root" without password is that I CAN connect but no database except test is shown when using a remote PC, but it works perfectly when running mysqlcc in the actual serer.

I have to mention that all my databases has as user "root" without password.

When I try to connect using anyother user it just wont connect saying mysqlcc.exe has generated an error and will be closed by windows... bla bla bla, windows error.
ME!!!
rcarabelli
 
Posts: 3
Joined: 23. November 2004 18:35

Postby Wiedmann » 23. November 2004 20:10

OK. In MySQL you have 2 users:
"root@localhost" --> privileges "ALL"
"Any@%" --> privileges "only connect"

So, if you connect from localhost with "root", all is correct. If you connect from another host with the user "root", you have the privileges from the user "Any".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby taustin » 24. November 2004 01:53

If you go to http://localhost/phpmyadmin/, you can go to Priviliges (on the main screen) and review users, and add new ones.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby rcarabelli » 24. November 2004 06:14

Thanx a lot, the user had all the priviledges to NO database :p
It is working now and perfectly
ME!!!
rcarabelli
 
Posts: 3
Joined: 23. November 2004 18:35


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests