Problems with local Redirection (on vhosts)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems with local Redirection (on vhosts)

Postby starms » 02. November 2004 17:28

Hello,

I am having problems getting a local redirect working on my apache installation... I am running a Plone server on port 8888 and PHP / Apache / MySQL on port 80. I am now trying to get plone to work through apache through redirects but it is not working... The problem being that the vhost is giving 403 messages on any url I try to redirect into.

I have been playing around with different combinations of configurations for about a week - with no avail... Does anybody have an idea what I am doing wrong?

Apache Version:
Apache/2.0.52 (Win32) mod_ssl/2.0.52 OpenSSL/0.9.7d PHP/5.0.2
from an xampp installation

Virtual Host Code:


NameVirtualHost *:80
#default
<VirtualHost *:80>
ServerName localhost
DocumentRoot "C:/webroot"
</VirtualHost>

#plone
<VirtualHost *:80>
ServerName www.myserver.co.uk
RewriteEngine On
RewriteRule ^/(.*) http://localhost:8888/$1 [P]
</VirtualHost>

I have mod_proxy and mod_rewrite enabled, and have set default directories to

<Directory />
Options All
AllowOverride All
Order allow,deny
Allow from all
</Directory>

my error log gives the following error

[Tue Nov 02 20:18:13 2004] [error] [client <IP Address>] client denied by server configuration: proxy:http://localhost:8888/

I'm sure it is something really simple but I can't work out the problem whatsoever, any help will be greatly appreciated.
starms
 
Posts: 1
Joined: 28. October 2004 16:50

Return to XAMPP for Windows

Who is online

Users browsing this forum: atrdriver and 43 guests