mercury mail/32

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby taustin » 07. November 2004 21:32

T-Shot wrote:My error message:


Ran into problems sending Mail. Response: 553 We do not relay non-local mail, sorry.

DEBUG MODE

Line : 152
File : E:\xampp\htdocs\Tippie-Forum\includes\smtp.php



in mercury i set my SMTP server to:
Do not permit SMTP relaying of non-local mail


Try going in to the Coniguration menu, to MercuryS SMTP Server, to the Connection Control tab. Click on Add Restriction, and put in 127.0.0.1 in the first box. Leave the second box blank. Make sure the Attributes are to Allow connections, and check the top box (Connections from this address range may relay mail through this server).

That should take care of it.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 07. November 2004 22:07

great,

Thank you very much m8!!!
All seems to work now, i get a message that mail is send.
Havent received anything yet, but so far so good!!

Thanx a million m8!

Regards

T-Shot
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby T-Shot » 07. November 2004 23:53

Ok, spook to soon..

It seems everything works, but i never get mails...

Now if i look at Mercury, everything points out that a mail has been sent,
only in the window of the mercury SMTP Client (end-to-end version)
it gives me this error:

Processing job MO00001A
Temporary error 249 (temporary MX resolution error) resolving 'planet.nl'

Planet.nl is from the adress i try to send mail to.

You know how to solve this too?
You have been a great help so far, many thanx for that,
hope you can guide me a bit further ;)

thanx
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 08. November 2004 00:19

T-Shot wrote:Ok, spook to soon..

It seems everything works, but i never get mails...

Now if i look at Mercury, everything points out that a mail has been sent,
only in the window of the mercury SMTP Client (end-to-end version)
it gives me this error:

Processing job MO00001A
Temporary error 249 (temporary MX resolution error) resolving 'planet.nl'

Planet.nl is from the adress i try to send mail to.


That sounds like a problem with Windows, or maybe a problem with the domain records (not likely, though).

To check those settings, do to the Start menu, and click on Run. Type in "cmd" (without the quotes). This should open a DOS windows. Type in "ipconfig /all" (again, without the quotes). This will show you all the network settings for the machine. There should be at least two DNS Servers, towards the bottom. If there's not, you'll need to enter some. If there is, they may need to be changed. Let me know what you get.

T-Shot wrote:You know how to solve this too?
You have been a great help so far, many thanx for that,
hope you can guide me a bit further ;)


I had to learn it the hard way. No point in letting all that sweat go to waste. :)
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby T-Shot » 08. November 2004 01:11

none...

Probably because i connect through a router?
T-Shot
 
Posts: 22
Joined: 01. October 2004 12:28

Postby taustin » 08. November 2004 07:30

T-Shot wrote:none...

Probably because i connect through a router?


You're probably using DHCP. In theory, Mercury should be able to pick that up, but apparently not.

You can try entering DNS servers manually in the properties of the network connection*. Ideally, you should use your ISPs, but any should work for testing. Mine are 208.57.67.55 and 208.57.67.52.

*If you don't know how to get to that, go to the Start Menu, and open the Control Panel. If you're in XP, go to Network and Internet Connections. Open Network Connections. There should be an icon for each network interface - probably only one (or maybe two, if you have a modem installed). Right click on that, and open Properties. Double click on Internet Protocol (TCP/IP). There should be a radio button towards the bottom for "Use the following DNS server addresses." Make sure that is selected, and enter both IP addresses. Once you close all the windows, the settings should be in place.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Postby godsdead » 19. July 2006 14:19

ROFL! omg thanx so much taustin, all works fine foe me now, and.. It even sends to gmail without fail :]

I am soo happy, now i have a Full workign server :D wooooooooooo!

and i found out about that i have a DNS on my computer with this server.. so that means if i set it to somehow static IP. would that make my DNS static..?
If thats possible can i setup a Domain to it then?
GodsDead.com
godsdead
 
Posts: 12
Joined: 19. July 2006 09:20
Location: Clacton on sea

Postby wolfshaven » 19. July 2006 21:46

XAMPP Should come with sendmail and it should be located in ...\xampp\sendmail. At least my copy did.

Most boards will look for sendmail to send outgoing mail through and you shouldnt have to use mercury or any other mail service.
wolfshaven
 
Posts: 2
Joined: 19. July 2006 21:18
Location: USA

Postby Izzy » 20. July 2006 00:57

Good to see the Search facility being used on the forum even if it does resurrects a relevant 2 year old thread. :D
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby godsdead » 20. July 2006 08:35

Haha yea, well... I thought it'd probily been posted here befor ^_^ and i couldnt be the only one that likes to write Email snippets lol

Right.. erm.. any answers abotu teh DNS stuff i asked?
and also, And how do i setup Mercry so that i can recive emails?
And setup of email accounts etc..
I have a no-ip account with there programme that sends my IP to there servers updateing it etc.. for my domain names there...
that could help with setting up email addresses?
GodsDead.com
godsdead
 
Posts: 12
Joined: 19. July 2006 09:20
Location: Clacton on sea

Postby Izzy » 20. July 2006 11:06

You need to set up a primary MX record in your domain's zone file at no-ip.

Looks like this:
Code: Select all
yourdomain.com.   14400     IN   A     111.111.111.111
yourdomain.com.   14400     IN   MX   0   your.servername.com.

The 0 can also be 10 or any other low number.
A secondary MX record would have a higher number than the lowest number for your primary MX record.
So if you use 0 for the primary you would use 10 for your secondary.
It is just to make the primary and secondary distinguishable.

Note the . after yourdomain.com and the . after your.servername.com these are critical and must not be omitted as your zone file will not work else.

You will need to use your.servername.com in Mercury mail as the same as your MX record. Makes sense as your IP will be tied to both.

You may also need an alias for your mail server like this:

Code: Select all
mail   14400   IN   A   111.111.111.111


Subsitute 111.111.111.111 with your own IP.

This will allow you to use mail.yourdomain.com in your e-mail client.
This is optional as you can use just yourdomain.com in your e-mail client as long as you have an MX record with your dns provider.

I use zoneedit.com for my DNS and I can set up my MX records in the supplied zoneedit control panel. I am assuming that no-ip has a control panel also.

That should take care of the DNS finding your instance of Mercury. Now you need help to set up Mercury.

I found this a while back and copy/pasted it to a text file on my PC. Here it is for you if it helps. I don't use Mercury so have no idea if it works. If anyone knows any problems with this tut or can add/improve it please feel free to do so. :)

Edit: There is a very good MurcuryMail Help file in Windows Help format in the xampp/mercurymail directory called mercury.hlp. This is as good as any help manual I have seen for a free product.

Good Luck! :)
Last edited by Izzy on 04. September 2006 19:20, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby godsdead » 20. July 2006 12:45

*joy'us run*
Woohoo!
cheers dood ^_^ :P
GodsDead.com
godsdead
 
Posts: 12
Joined: 19. July 2006 09:20
Location: Clacton on sea

Postby godsdead » 12. June 2007 16:50

Hey there, wow, this was a long time since i visited the boards here, since my last post i have moved house and provider, new computer.. and the new updated server =]

I havent had the SMTP running yet, so came back here to this post, iv gone through the steps and recive:

Temporary Error 249(tempory MX resolution error) resulving 'gmail.com'
All signs show email has been posted, i have port fordwarded port 25 in my router for my SMTP, but i still cant get that emil sent out!!!

Some help please =]

I am running vista, if this causes any problems?

Soon to get my linux box.. hopefully
GodsDead.com
godsdead
 
Posts: 12
Joined: 19. July 2006 09:20
Location: Clacton on sea

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests