Questions from a new XAMPP user

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Questions from a new XAMPP user

Postby JonathanS » 31. October 2004 02:49

Howdy all. A friend of mine told me about XAMPP, and how he
likes it because its handy to put on his USB Stick Drive and take with him.

I got this because I'm running IIS by default (half hearted attempt @ ASP)
and wanted to still be able to use Apache to test my sites on,
since I use .HTACCESS files sometimes (mainly for mod_rewrite).
Anyways, I have a few questions to ask concerning XAMPP.

1. I'm running XAMPP (full) on a external hard drive; I want
to generate a self-signed certificate (SSL) using OpenSSL.

However, I cannot open 'CMD' and type in cd e:\
I tried, but it won't change the directory to the E (external) drive.

Is there any way around this to generate a SSL Certificate?
If so, how? What would be the code and method, so forth?

2. I use a reseller host, to host multiable sites (alot cheaper).
However, their AWStats doesn't resolve IPs, so AWStats cannot
give country data; I tried to, but can't figure out how to install AWStats.
Any ideas? Also once I do, where can I store log files from my sites, so
that AWStats will process them for me??

3. I notice that 'mysql_stop.bat' does NOT work for me.
It pops up a CMD window, beeps, and closes it. But it does not
turn off MySQL nor close the other MySQL CMD window. Also if I do
close the MySQL CMD window, the process does not end.

Only way around this I've found (so far) is 'xampp_stop.exe'.
Am I supposed to use the *_start.bat files, or the 'xampp_start.exe' file,
to start up Apache and MySQL? I do not need FileZilla or Mercury.

:) Thanks for making this excellent product,
and I hope you guys keep up the good work.

Regards,
- Jonathan.

*edited* Okay I found a solution for the CMD;
just copy the 'cmd.exe' file from /WINNT/system32/ to the E drive.

But I can't find any sites on info to generate a SSL Cert for Windows.
JonathanS
 
Posts: 31
Joined: 31. October 2004 02:36

Postby Wiedmann » 31. October 2004 04:56

1a) However, I cannot open 'CMD' and type in cd e:\

Code: Select all
Start --> Run --> cmd.exe [Ok]
e: [return]
cd \ [return]


1b) Is there any way around this to generate a SSL Certificate?

http://community.apachefriends.org/f/viewtopi ... 8057#28057

3) I notice that 'mysql_stop.bat' does NOT work for me.

http://community.apachefriends.org/f/viewtopi ... 3982#33982
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby JonathanS » 31. October 2004 05:31

I cannot read German :( Plus all the translators (online) stink.
http://fets5.freetranslation.com/?seque ... 57%2328057

I'll try the MySQL part (@least translator didn't mess that up)
tomorrow morning when I wake up.
JonathanS
 
Posts: 31
Joined: 31. October 2004 02:36

Postby DragonFire » 31. October 2004 15:31

Let me see if I understand the SSL part :wink:

Create makecert.bat in \xampp\apache\bin

In the .bat file put:
Code: Select all
@echo off
set OPENSSL_CONF=C:/xampp/apache/bin/openssl.cnf
mkdir ..\conf\ssl.crt >nul 2<&1
mkdir ..\conf\ssl.key >nul 2<&1
openssl req -new -out server.csr
openssl rsa -in privkey.pem -out server.key
openssl x509 -in server.csr -out server.crt -req -signkey server.key -days 365
set OPENSSL_CONF=
del .rnd
del privkey.pem
del server.csr
move /y server.crt ..\conf\ssl.crt
move /y server.key ..\conf\ssl.key


Good questions BTW. I will use this code myself.
DragonFire
 
Posts: 9
Joined: 15. October 2004 12:11
Location: Rochester, NY

Postby JonathanS » 31. October 2004 19:36

Okay I put that in, re-did the C:\ to my drive letter (E:\)
and what not; saved to E:\xampp\xampp\apache\bin\
and then double-clicked it to run the file.

It asked for a pass phrase, then re-aksed.
Went through all this stuff, I caught the word "unable" then closes.

Now, it does make the directory 'ssl.crt' but not 'ssl.key'.
Also it does not make any files in the directory 'ssl.crt'.

Any idea what I'm doing wrong? :?

*edited*
I tried this: http://www.mail-archive.com/tomcat-user ... 03507.html

But it says the following...
unable to find 'distinguished_name' in config
problems making Certificate Request
1108:error:0E06D06A:configuration file routines:NCONF_get_string:no conf or evi
roment variable:.\crypto\conf\conf_lib.c:325:


*edited 2nd time*
I tried this one: http://raibledesigns.com/wiki/Wiki.jsp?page=ApacheSSL
Works like a charm :D Again, I must say this is a excellent package :D

Thanks for making XAMPP!
JonathanS
 
Posts: 31
Joined: 31. October 2004 02:36

Re: Questions from a new XAMPP user

Postby chuyskywalker » 02. November 2004 08:33

JonathanS wrote:2. I use a reseller host, to host multiable sites (alot cheaper).
However, their AWStats doesn't resolve IPs, so AWStats cannot
give country data; I tried to, but can't figure out how to install AWStats.
Any ideas? Also once I do, where can I store log files from my sites, so
that AWStats will process them for me??


Ever get that installed? I have had Zero luck so far. :(
chuyskywalker
 
Posts: 11
Joined: 23. October 2004 05:17

Postby JonathanS » 02. November 2004 18:22

Nope; I couldn't get the Perl addon installed,
kept saying couldn't find my "XAMPP Win32" path.

Tried manually extracting the zip, okay, and
then ran the setup file, set it up w/ Perl ~ then
XAMPP stopped working :?

So, so far I got zero luck :(
Guess thats my luck for installing on my external hard drive :(
JonathanS
 
Posts: 31
Joined: 31. October 2004 02:36

Postby JonathanS » 02. November 2004 19:41

Okay I tried the self-extracting ZIP of the Perl Addon,
and then ran the setup_xampp file and it worked.

@first I didn't think it did, because it took *ages*
to load http://localhost :? But when it did, it didn't
go slow much afterwords. (Still, though, slighly slower than before)

I tried to install AWStats, btw ~ and no matter what
I did, it just didn't wanna work for me :( So, oh well.
JonathanS
 
Posts: 31
Joined: 31. October 2004 02:36

Postby chuyskywalker » 03. November 2004 16:12

JonathanS wrote:I tried to install AWStats, btw ~ and no matter what
I did, it just didn't wanna work for me :( So, oh well.


Damn! I can't seem to find anyone who has installed this and got it working. AWStats walks all over Webalizer for stats, but the last awstats "add on" for XAMPP was made something like 1.5 years ago and I don't think works anymore (nor does it have any instructions, even if it does work...)
chuyskywalker
 
Posts: 11
Joined: 23. October 2004 05:17

Postby Kristian Marcroft » 03. November 2004 16:19

Hi,

AFAIK the AddOn was created for the Linux Version...
I host the AddOn but I have no idea if it works or not.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby chuyskywalker » 03. November 2004 23:44

yeah, that could have been the one i found :)
chuyskywalker
 
Posts: 11
Joined: 23. October 2004 05:17


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests