Using phpwebsite with XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Using phpwebsite with XAMPP

Postby black_prometheus » 27. October 2004 20:07

Dear Forum,

I'm trying to use phpwebsite with XAMPP under Windows 2000. Both are installed and running, but how do I modify httpd.conf so that when I open localhost in a browser, instead of XAMPP coming up phpwebsite comes up? Right now in httpd.conf, documentroot is set for xampp. If I modify it to set it to the phpwebsite directory, which is in htdocs, xampp can't start properly. I don't visitors to my website running in phpwebsite to have to type the full path to phpwebsite underneath htdocs. I hope this is clear.

Thanks,

David
black_prometheus
 
Posts: 2
Joined: 27. October 2004 15:36

Postby JusticeIsDead » 27. October 2004 23:38

im alittle new at this, but heres an idea you can give a shot:

i am assuming that the directory that the root is pointing to is sumthing like this c:\www\xampp\htdocs

so pretty much htdocs folder is where you root directory is located at, so what i would do, if changing the root inside httd.conf doesnt work, is make a new folder inside of htdocs called "default" [or whatever u want] and take all the files [not the folders just the files] out of htdocs and place it in the new folder then take ur php site and put it all in htdocs, this was ur php site will be in ur root directory.

the only other altenative i would think would be to reinstall xampp to a different directory, but you would still have all the default files in the htdocs folder that would have to be taken out.

i do find it rather odd that changing the root inside httpd.conf is not working, are you sure that you are putting in a valid path? ex.

c:\www\newsite

if this directory doenst exist then this would cause it not to work correctly. i hope this helps you.
JusticeIsDead
 
Posts: 16
Joined: 26. October 2004 23:39

Update

Postby black_prometheus » 28. October 2004 00:45

Ok,

It looks like I goofed a little. There are (2) documentroot settings in httpd.conf. After reading your response I modified the 1st documentroot setting in httpd.conf. Of course I ran "xampp basic stop" first. After the change I ran "xampp basic start". Now here's what happened. After running "basic start", xampp opens a browser. Since I don't know german, I click on the english link. When the browser tries to open xampp it displays a "page not found" error message. I ignored that and tried to open my phpwebsite by just typing "localhost" in my browser and hitting return. It worked just fine. So the problem that remains, and this was my concern, is that the xampp main page no longer comes up when I run "xampp basic start". How can I resolve that problem, since I'd like to be able to run phpmyadmin, which is linked to from the main xampp page. I'm not sure if other problems have been created as result of the change to httpd.conf as well.
black_prometheus
 
Posts: 2
Joined: 27. October 2004 15:36

Re: Using phpwebsite with XAMPP

Postby taustin » 28. October 2004 00:49

black_prometheus wrote:Dear Forum,

I'm trying to use phpwebsite with XAMPP under Windows 2000. Both are installed and running, but how do I modify httpd.conf so that when I open localhost in a browser, instead of XAMPP coming up phpwebsite comes up? Right now in httpd.conf, documentroot is set for xampp. If I modify it to set it to the phpwebsite directory, which is in htdocs, xampp can't start properly. I don't visitors to my website running in phpwebsite to have to type the full path to phpwebsite underneath htdocs. I hope this is clear.


You can get the error message by starting apache in a command prompt box. If you don't know how to do this:

Right click on a blank spot on the desktop.
Select New-->Shortcut
Type in "cmd.exe" (without the quotes) and click on Next
Type in whatever name you want, and click on Finish
Now right click on the new shortcut, and select Properties.

In the "Start In" box, type in "C:\apachefriends\xampp\apache\bin" (Note which way the slashes go) and click OK.

Now, double click on this shortcut, and you should have a black command prompt window.

Now, type in apache and hit Enter. This will give you a full error message. It should tell you that some directory can't be found, but could be something else.
taustin
 
Posts: 150
Joined: 24. September 2004 00:23
Location: Huntington Beach CA

Re: Update

Postby laplace » 01. November 2004 09:57

to access phpmyadmin just type http://localhost/phpmyadmin
User avatar
laplace
 
Posts: 7
Joined: 26. October 2004 18:09
Location: Norway


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy, mark.mcdonald and 48 guests