Parse error when trying to load index.php

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Parse error when trying to load index.php

Postby insomn3ak » 18. October 2004 20:07

I've recieved the source code for a clients site and I'm trying to migrate it to a new site that I'm developing. When I try to launch the index.php page, I get this error message:


Parse error: parse error, expecting `T_STRING' or `T_VARIABLE' or `'{'' or `'$'' in D:\data\websites\old_mlstrivalley\trivalleymlssearch\inc\pm_classes.php on line 66


Here are lines 65 and 66 in pm_classes.php:

// create a database connection for this object
$this->sql = mysql_pconnect("localhost", $this->"root", $this->);


I can't see any errors in the syntax, however I'm not that familiar with mysql yet. Also, I didn't change anything in pm_classes.php yet.

Thanks for any help anyone can give...
insomn3ak
 
Posts: 13
Joined: 15. October 2004 09:05

Postby Wiedmann » 18. October 2004 20:35

$this->sql = mysql_pconnect("localhost", $this->"root", $tthis->);

I think it must be:
Code: Select all
$this->sql = mysql_pconnect('localhost', $this->'root', $this->'');
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby insomn3ak » 18. October 2004 20:49

hmmm...still getting the error after I made the change.
insomn3ak
 
Posts: 13
Joined: 15. October 2004 09:05

Postby insomn3ak » 18. October 2004 20:56

Would it help if I provided some code before and after line 66?

I know that it's generally not prefered for people to put large chunks of code in these message boards...it's not much though.
insomn3ak
 
Posts: 13
Joined: 15. October 2004 09:05

Postby Wiedmann » 18. October 2004 23:01

Or you can try this:

$this->sql = mysql_pconnect('localhost', 'root', '');
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby insomn3ak » 18. October 2004 23:16

That did the trick!
Much thanks!
insomn3ak
 
Posts: 13
Joined: 15. October 2004 09:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 32 guests