PHP mail() 10061<EOL>Connection refused

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP mail() 10061<EOL>Connection refused

Postby ProgXT » 03. February 2021 11:18

Hi, from and to addresses are the same. Why the connection is refused?

C:\xampp\sendmail\error
Code: Select all
21.02.03 10:11:19 : Socket Error # 10061<EOL>Connection refused.



Code: Select all
$header = "From: ...@gmail.com";
$to = "...@gmail.com";
$subject = "Subject";
$message = "Message";
$mail = mail($to, $subject, $message, $header);
var_dump($mail);



php.ini
Code: Select all
[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP=localhost
; http://php.net/smtp-port
smtp_port=587                                                                                        ;    smtp_port=25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = ...@gmail.com                                                            ;    me@example.com

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
; http://php.net/sendmail-path
;sendmail_path =
sendmail_path = "\"C:\xampp\sendmail\sendmail.exe\" -t"                                                ;     dodałem

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail().
;mail.force_extra_parameters =

; Add X-PHP-Originating-Script: that will include uid of the script followed by the filename
mail.add_x_header=Off



sendmail.ini
Code: Select all
[sendmail]

; you must change mail.mydomain.com to your smtp server,
; or to IIS's "pickup" directory.  (generally C:\Inetpub\mailroot\Pickup)
; emails delivered via IIS's pickup directory cause sendmail to
; run quicker, but you won't get error messages back to the calling
; application.


;smtp_server=smtp.gmail.com                                                                                ;    smtp_server=mail.mydomain.com
smtp_server=127.0.0.1

; smtp port (normally 25)

smtp_port=587                                                                                                            ;    smtp_port=25

; SMTPS (SSL) support
;   auto = use SSL for port 465, otherwise try to use TLS
;   ssl  = alway use SSL
;   tls  = always use TLS
;   none = never try to use SSL

smtp_ssl=auto

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=mydomain.com

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

debug_logfile=debug.log                                                                                            ;    było zakomentowane

; if your smtp server requires authentication, modify the following two lines

auth_username=...@gmail.com                                                                            ;    dodałem wartość
auth_password=...                                                                                            ;    dodałem wartość

; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines.  do not enable unless it is required.

pop3_server=
pop3_username=
pop3_password=

; force the sender to always be the following email address
; this will only affect the "MAIL FROM" command, it won't modify
; the "From: " header of the message content

force_sender=

; force the sender to always be the following email address
; this will only affect the "RCTP TO" command, it won't modify
; the "To: " header of the message content

force_recipient=

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting.  you can manually set the ehlo/helo name if required

hostname=
ProgXT
 
Posts: 1
Joined: 03. February 2021 11:05
XAMPP version: 8.0.1
Operating System: Windows 10 64-bit

Re: PHP mail() 10061<EOL>Connection refused

Postby Nobbie » 03. February 2021 14:03

You have specified "localhost" and/or 127.0.0.1 as SMTP server. Which server is running there?
Nobbie
 
Posts: 11916
Joined: 09. March 2008 13:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 101 guests