localhost without :8080

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost without :8080

Postby gerijsma » 14. August 2020 18:33

I reinstalled xampp on another pc. Now when I go to local site I suddenly have to enter localhost:8080/sitename before it was localhost/sitename. How do I get this working again without the insert {: 8080}
gerijsma
 
Posts: 3
Joined: 14. August 2020 18:24
XAMPP version: xampp-windows-x64-7.4.8-0-VC15
Operating System: Windows 10 64bit

Re: localhost without :8080

Postby Altrea » 14. August 2020 20:54

Change the Apache HTTP port back to port 80.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10342
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost without :8080

Postby gerijsma » 14. August 2020 21:46

Port 80 is in use by ??? When I change it to 80 then I get an error
gerijsma
 
Posts: 3
Joined: 14. August 2020 18:24
XAMPP version: xampp-windows-x64-7.4.8-0-VC15
Operating System: Windows 10 64bit

Re: localhost without :8080

Postby Altrea » 14. August 2020 21:50

Then this is the problem you need to solve.

The only way to get rid of the port in the url is to use the default port for this protocol, and the default port for protocol HTTP is 80.

Maybe we can assist you much better if you provide more debug information like the complete control panel log
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10342
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: localhost without :8080

Postby gerijsma » 15. August 2020 11:33

Have the ports in httpd.conf back to 80 and in the config screen. This is the result with a printout of the error codes.

12:25:53 [main] Initializing Control Panel
12:25:53 [main] Windows Version: Enterprise 64-bit
12:25:53 [main] XAMPP Version: 7.4.8
12:25:53 [main] Control Panel Version: 3.2.4 [ Compiled: Jun 5th 2019 ]
12:25:53 [main] You are not running with administrator rights! This will work for
12:25:53 [main] most application stuff but whenever you do something with services
12:25:53 [main] there will be a security dialogue or things will break! So think
12:25:53 [main] about running this application with administrator rights!
12:25:53 [main] XAMPP Installation Directory: "x:\xampp\"
12:25:53 [main] Checking for prerequisites
12:25:54 [main] All prerequisites found
12:25:54 [main] Initializing Modules
12:25:54 [Apache] Problem detected!
12:25:54 [Apache] Port 80 in use by "Unable to open process" with PID 4!
12:25:54 [Apache] Apache WILL NOT start without the configured ports free!
12:25:54 [Apache] You need to uninstall/disable/reconfigure the blocking application
12:25:54 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:25:54 [main] The FileZilla module is disabled
12:25:54 [main] The Mercury module is disabled
12:25:54 [main] The Tomcat module is disabled
12:25:54 [main] Enabling autostart for module "Apache"
12:25:54 [main] Enabling autostart for module "MySQL"
12:25:54 [main] Starting Check-Timer
12:25:54 [main] Control Panel Ready
12:25:54 [Apache] Autostart active: starting...
12:25:54 [Apache] Problem detected!
12:25:54 [Apache] Port 80 in use by "Unable to open process" with PID 4!
12:25:54 [Apache] Apache WILL NOT start without the configured ports free!
12:25:54 [Apache] You need to uninstall/disable/reconfigure the blocking application
12:25:54 [Apache] or reconfigure Apache and the Control Panel to listen on a different port
12:25:54 [Apache] Attempting to start Apache app...
12:25:54 [mysql] Autostart active: starting...
12:25:54 [mysql] Attempting to start MySQL app...
12:25:55 [Apache] Status change detected: running
12:25:55 [mysql] Status change detected: running
12:25:55 [Apache] Status change detected: stopped
12:25:55 [Apache] Error: Apache shutdown unexpectedly.
12:25:55 [Apache] This may be due to a blocked port, missing dependencies,
12:25:55 [Apache] improper privileges, a crash, or a shutdown by another method.
12:25:55 [Apache] Press the Logs button to view error logs and check
12:25:55 [Apache] the Windows Event Viewer for more clues
12:25:55 [Apache] If you need more help, copy and post this
12:25:55 [Apache] entire log window on the forums

In Netstart
Adress port pid Name
0.0.0.0 80 4 system
gerijsma
 
Posts: 3
Joined: 14. August 2020 18:24
XAMPP version: xampp-windows-x64-7.4.8-0-VC15
Operating System: Windows 10 64bit

Re: localhost without :8080

Postby Altrea » 15. August 2020 11:50

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 10342
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 107 guests