BUG in XAMPP Control panel - apache start

Problems with the Windows version of XAMPP, questions, comments, and anything related.

BUG in XAMPP Control panel - apache start

Postby marialp » 28. October 2019 15:15

Description: When the control panel starts it does not detect the Apache process even though it is running. This occurs only under a specific set of conditions.

Versions affected: I found it in 3.2.4. i have not tested in others

Steps to reproduce
1 - Start the control panel as an administrator
2 - Start Apache as a process (not a service).
3 - Close the control panel and start it again without administrator privileges.

Result
Apache is not green and the Start button is enabled.
If you try to start it it will fail with red error messages in the log window.

Workaround.
Run the control panel as an administrator again and stop the process .
You should then be able to start it when not running as an administrator again.

I am looking through the code and will post the solution if I manage to find it.
marialp
 
Posts: 10
Joined: 19. October 2019 14:34
XAMPP version: 3.2.4
Operating System: Windows 10

Re: BUG in XAMPP Control panel - apache start

Postby marialp » 28. October 2019 18:57

At first I thought that this behaviour is not necessarily an issue because it is debatable as to whether you should be able to stop an application started by an administrator if you do not have administrative privileges but as you can stop Apache if it was started as a service the behaviour is at least inconsistent.

I have found the line that is causing the issue but I do not have a solution yet.

file: uProcesses_new.pas
line62 : hProcess := OpenProcess(PROCESS_QUERY_INFORMATION or PROCESS_VM_READ, False, PID);

It looks like it will only return a process path if the application is running with administrative privileges.
Also this line of code is only called for apache (not any of the other modules) and only if it is not running as an application so that explains why nothing else is failing.

I am still getting to know the code base so although a potential solution would appear to be to access the process as other modules do the fact that apache has a special way of doing things make me think I am missing something important so looking into that.
marialp
 
Posts: 10
Joined: 19. October 2019 14:34
XAMPP version: 3.2.4
Operating System: Windows 10

Re: BUG in XAMPP Control panel - apache start

Postby marialp » 28. October 2019 18:59

Correction: I meant if it is not running as a service.( that is it is running as a process)
marialp
 
Posts: 10
Joined: 19. October 2019 14:34
XAMPP version: 3.2.4
Operating System: Windows 10

Re: BUG in XAMPP Control panel - apache start

Postby tr6to986 » 08. November 2019 14:18

Hi Marialp. I am having exactly the same issues. Have you made any further progress?
tr6to986
 
Posts: 8
Joined: 05. November 2019 18:23
XAMPP version: 5.6.28
Operating System: Windows 10, build 1903


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests