Page 1 of 1

mysql_stop.bat not working in latest version

PostPosted: 12. September 2019 00:08
by hedgehog90
When running mysql_stop.bat I get the following output:
pv: No matching processes found


The pv executable (PrcView) no longer detects mysqld.exe or httpd.exe, unlike previous versions.

Also, unlike a previous version of XAMPP (7.0.1), mysqld behaves differently and wrongly it seems.
In the latest version (7.3.9), if I run start_mysql.bat a command prompt opens. If I close that command prompt, the mysqld.exe process remains.
In 7.0.1, if I run start_mysql.bat a command prompt opens. If I close that command prompt, the mysqld.exe is killed.
The latter is the expected behaviour.

Re: mysql_stop.bat not working in latest version

PostPosted: 13. September 2019 12:45
by Nobbie
hedgehog90 wrote:The latter is the expected behaviour.


It depends.

If mysqld is started directly from the Batch Job, it will be killed when the terminal is closed.
If mysqld is started as a service, the service will NOT be killed when the terminal is closed.

There is an option in Xampp Control Center for running Apache/MySQL as service or not.

I dont know the syntax for mysqld, but for example Apache service httpd.exe can be run as service via using the option "-k" on the commandline. Maybe there is also such an option for mysqld. I dont have a Windows installation for checking that.

Re: mysql_stop.bat not working in latest version

PostPosted: 16. September 2019 09:32
by gonzalo
Hi hedgehog90,

Thanks for your report. This is a known issue of the "pv.exe" binary not being able to handle 64-bits processes (e.g. Apache and MariaDB). We will work on fixing this issue for the next release.

In the meantime, you can use the `killprocess.bat` script in the XAMPP installation directory. For stopping the MariaDB process, you can run the command below

Code: Select all
killprocess.bat" "mysqld.exe"


Regards,
Gonzalo

Re: mysql_stop.bat not working in latest version

PostPosted: 25. September 2019 22:08
by gonzalo
Sorry, there's a typo in my previous post that I can no longer edit. There's an extra quotation mark. The correct command should be read as below

Code: Select all
killprocess.bat "mysqld.exe"

Re: mysql_stop.bat not working in latest version

PostPosted: 09. October 2019 14:58
by gonzalo
We released a new version of the XAMPP installers fixing the issue with the mysql_stop.bat and apache_stop.bat scripts.

New Installers version: 7.1.32-1 / 7.2.23-0 / 7.3.10-0