clean install of 7.3.8 - lots of errors

Problems with the Windows version of XAMPP, questions, comments, and anything related.

clean install of 7.3.8 - lots of errors

Postby troypiggo » 10. August 2019 10:08

Hi there. Have done a clean install of 7.3.8 on Win10. Getting a lot of errors. Apache and MariaDB start fine, and can access the localhost/phpmyadmin page, however there's lots of red messages about
mysqli_real_connect(): (HY000/1045): Access denied for user 'pma'@'localhost' (using password: NO)
on the front page. I solved this by changing user pma to root in config.inc.php

I am also getting this error message if I try to click on the databases
#1932 - Table 'phpmyadmin.pma__tracking' doesn't exist in engine
Any ideas on solving this one?
troypiggo
 
Posts: 1
Joined: 10. August 2019 09:55
XAMPP version: 7.3.8
Operating System: Windows 10

Re: clean install of 7.3.8 - lots of errors

Postby Altrea » 10. August 2019 11:37

I can confirm this.

It is recommend not to use the XAMPP versions including MariaDB 10.3 up to the point the database corruption issue is solved.
So i would recommend to use XAMPP 7.3.5 instead.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 9741
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: clean install of 7.3.8 - lots of errors

Postby dbagnara » 10. August 2019 21:53

For what it is worth, phpmyadmin will not run on my clean install. The pma user is missing from mysql.

Win10 clean install of 7.3.8 (running as administrator)
Open control panel (as administrator) and started apache and mysql.
From a command log into mysql
Code: Select all
\xampp\mysql\bin\mysql.exe -u root

then checked the mysql.user table for a pma user
Code: Select all
select distinct user from mysql.user ;

The only user in there is root.
Code: Select all
+------+
| user |
+------+
| root |
+------+

1 row in set (0.000 sec)

On an older installation I have (7.1.11), there is a pma user that was set up by the intallation process.
dbagnara
 
Posts: 1
Joined: 10. August 2019 21:35
XAMPP version: 7.3.8
Operating System: Win10

Re: clean install of 7.3.8 - lots of errors

Postby cb » 10. August 2019 22:38

Also confirm this occurs after a clean install of 7.3.8, without doing anything further like restoring backed up db's etc.

This is more than just the occasional errors from Mariadb that has been reported earlier. Would it not be prudent to pull the 7.3.8 release completely?
cb
cb
 
Posts: 18
Joined: 11. June 2008 22:48

Re: clean install of 7.3.8 - lots of errors

Postby cb » 11. August 2019 07:08

Another suggestion - could the new releases include an older (safe) version of Mariadb?
cb
cb
 
Posts: 18
Joined: 11. June 2008 22:48


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests